Datasmith Directlink Between SketchUp and Unreal engine 5 Not Working

I am trying to use Unreal 5 to render.
I am running SketchupPro 2022 (as administrator).

I have successfully downloaded/installed the latest versions of:
1.Unreal engine 5
2… the Datasmith plugin.

Both Unreal and SketchUp show the plug-in but DIDN’T WORK - can’t establish a Directlink, no connection

I then downloaded/installed one version back of:
1.Unreal engine 5
2… the Datasmith plugin.

Same thing, DIDN’T WORK!- can’t establish a Directlink, no connection

I even tried adding “-messaging” to the target of my Unreal engine shortcut. No dice.
I’ve tried saving/exporting everything to same folders etc.

All the tutorials online make it seem seamless, and Ive exhausted every thread my search terms will produce.

Can someone point me in a useful direction?

Thanks So Much!

The latest datasmith exporter works only with sketchup 2023, you need to get a previous version of the plugin to be able to install it in sketchup 2022.

Thanks for your reply.

But as I stated in my post I reverted one version back and still didnt work.

Any ideas?


Have you tried installing sketchup 2023 and try to install there the datasmith exporter plugin?

I just tried it with SU 2023 and UE5.2 and it worked fine as per the documentation.

I tested the collab viewer template and ran it.
Enter runtime
press spacebar and choose “datasmith”

I thought about installing SketchUp 2023 but that would mean renewing my subscription months before it expires, costing me money.

I don’t understand what the collob template is ( Im not very tech savvy that way). If I install the collob template is that a way to establish a Direct link?

All I know is I was following a tutorial and able to do everything fine until it came to importing a direct link into Unreal via Datasmith which produced a window with no file to import.

I export using Datasmith to get the file extension then I get a window saying cannot establish a connection.


No, if your subscription is active you can use the latest version of sketchup, classic licenses were the ones that had you attached to an specific version of the program but with the current licensing method you can use any supported version you want including the latest one.

So I changed to using SU 2023. Using the latest unreal and Datasmith versions. Still the same issue.
I can import the file it just doesnt update with a Direct link.

Here is what I see when I go to the Connection Manager after exporting my file with the “.udatasmith”
extension, and when I try to use the Datasmith Importer in the Unreal Engine


What is and how do I use Collab?

I cant believe Im the only one with this issue?!

If you mean google colab, it’s a free rendering farm with quite powerful hardware, but you need to have everything ready to make just the render, you can’t add materials or assets or anything else, that must be done on another software, I don’t think it works for you if you just want to set everything up.
I haven’t used unreal engine much but from twinmotion you can import .skp files and every time you make a change to the model you just save it and click refresh on twinmotion and it automatically updates.

So I got it worked out! I had to uninstall everything and re-download/install everything! I was avoiding this as I live in the country with horrible internet connection.

Thanks for your help and attention!

Some times the longest solution is the fastest one.