Cylinders Rendering Incorrectly using HiddenLine Style

Hi All,
I’m using SketchUp to make a product idea of mine, and I’d like to render it in HiddenLine view for the best representation. However, the cylinder at the top of the drawing doesn’t show up, with only the grooves being visible.

Here is the model in the default style:
Imgur: The magic of the Internet (sorry, can’t upload more than one embedded image)
Here is the model in the HiddenLine style:

As you can see, the cylinder has no horizontal lines, which makes it look very odd. How can I fix this?

Perhaps:
profiles

Thanks so much, this worked

EDIT: It seems to work for the most part, but when I move to the top view one of the lines disappears, like so:

Could you add your model so we can check as I am unable to replicate your issue.
Top Hidden

have you checked if SketchUp actually uses your dedicated videocard?
[menu] Window > Preferences > OpenGL >Graphic Card Details

There is a glitch that some lines are not being displayed when using the internal (Intel) card

We are just guessing without the model file. Sketchy Edges-type style?