Customizing mouse buttons problems

I have really become frustrated with trying to customize my Logitech M705 mouse buttons. I downloaded the latest version of SetPoint and tried to figure out resolve this. Under the “My Mouse” tab…‘Select Button’ box, I highlight the ’ 3 Middle Button’, then select ‘Middle Button’ under the ‘Select Task.’ At this point there is no option for assigning keystrokes. Then, with ‘3. Middle Button’ still selected in the ‘Select Button’, I choose the ‘Keystroke Assignment’ option under the ‘Select Task’ column.

At this point, the item 3 option in the ‘Select Button’ changes to ‘Keystroke Assignment’ and gives me the option to assign a keystroke… I hit the ‘o’ key which I have established as the keyboard short-cut for ‘Orbit’ (in SketchUp/Window/Preferences, and it works…I tested it). I then select the Apply option at the bottom…try it out, but does not work.

I go back to SetPoint, go to ‘Advanced Settings,’ Choose to ‘Enable application-specific settings,’ hit Apply, then configure…Add SketchUp to the ‘Select Application’ list, only to be told there are no keyboard assignment options when SketchUp is chosen.

Obviously, I am missing something. Tried to get a download of uberOption but cannot seem to find the download.

Feeling pretty dumb right about now.

Thames, just assigning the Middle Button function to the middle button of the mouse should be enough. You don’t need to assign it to a keystroke because SketchUp is already set up to recognize the middle button function as the call for Orbit.

I assigned those two side buttons to keystrokes for Ctrl+Y and Ctrl+Z when we were looking at it on Friday.

I did assign/try just the middle button option just now…not working…going to close everything, restart, then try again.

Hmmm… It should work.

Another thing that you might try is uninstalling the Logitech software altogether.

Out of curiosity, does the center mouse button work in other programs?

That is what I have my SetPoint setting as, for my Logitech M100 mouse.

Yes, and it works for scroll/zoom in SketchUp

I’ve tried it. Button works in other apps. for app-related features.

The button works or just the scroll/zoom function?