Cursor Offset

I just installed Sketchup Pro 2023. I have a similar problem someone post in 2015 that the Cursor is Offset. Mean the cursor position of the cursor is off so you can’t click where you want. The solution in 2015 seems like resolve by OpenGL but is no longer available in 2023. Appreciated if anyone have solution.

Look under Preferences>Graphics. Also make sure you have the latest graphics drivers installed. Go to the manufacturer’s site to get them. Don’t trust Windows to tell you if they are up to date.

1 Like

And, if your graphics card information is correct, go to Preferences>OpenGL, uncheck “Use Fast Feedback” and restart SketchUp.


Now it would be Preferences>Graphics …
Screenshot - 9_17_2023 , 10_10_59 AM

1 Like

Yes, my bad…



I have tried below suggestions but seems like the problem still remained.

According to the Intel website, this is the latest driver for your integrated graphics (if your profile is correct:

It wouldn’t hurt to also check for an update to your mouse drivers.

Hi Anssi,

Yes, I have updated the driver with this version. But still not resolving the problem.

The Intel Graphics 520 was released in 2015, so it is a bit behind the current releases.


The latest version is like what Anssi mentioned. Release on Dec 2022 and i have updated it. But the version unable to resolve the problem

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.