Cursor offset from crosshair


#1

Hi!
I have a “tiny problem”.
I just started to use Sketchup pro 2015. Few days ago I closed my software, today I opened and everything seems like its “offset”. I might push something when I closed the Sketchup.
I attached few pics please check it out. When I opened my “project” the little house was prolonged. I tryed to render but inside the room the furnitures where prolonged as well. If this is not enough even the cursor behaves funny. There is a distance between my cursor and the crosshair.
I realized that if I pull the crosshair in the corner of the screen my cursor (pencil) is exactly in the middle of the screen. Somehow everything became offset.

If you could help me I would be grateful.
Sorry for my English, but English is not my first language.

Thank you
Emőke


#2

Hello to you, I have not seen this issue before but what I can say. That someone will come along that will have information or be able to offer you a explanation. The photos do show what you are tring to explain but if you could also include a copy of the file. Just save it and upload it as you did the photos. This will allow others to open it and see if the same things happens to them on their system. It will help pin point the cause and remedies. It may also be a simple setting change you can apply. Hang tight as you will receive more info as there are very knowledgeable folks here to help. I have never seen this but I am sure someone will reply!!


#3

I’m not sure about the crosshairs but it looks like you’ve got the camera’s angle of view set as wide as it’ll go. Get the Zoom tool from the Camera toolbar or Large Toolset and type something like 50mm or 35deg and hit Enter. See if that helps.

You might also experiment with changing OpenGL settings under Preferences in the SketchUp menu and see if that has any impact on the crosshair offset thing…


#4

Do you need the crosshairs? When you create objects, SkethUp inferencing will keep you informed of whether they are following the axis directions. IMO the crosshairs only add to screen clutter and I never have used them. Is the standard cursor doing the same thing? It might help to update your graphics card and, perhaps, mouse drivers (edit-seeing you are on a Mac, have you installed all the available OS X updates?).

Anssi


#5

I think Anssi, the problem is even without the crosshairs the position of the cursor is off so you can’t click where you want.
Imagine your finger will only make contact with something at a point you can’t see roughly 50mm to the right and up a bit, now try to push a button.


#6

Oh my God!!! Thank you @DaveR for helping. The Open Gl was the problem.
No everything seems OK.
I am so so thankful, I wish I could invite you for a beer lol! If you come to Budapest, contact me, I own you!

Lots of thanks again!

Emőke


#7

Guys, thank you for your time and help!
I am really thankful for all of you.
You fixed the problem, it was the OpenGL or what… unfortunately I am a “baby” with using Sketchup. :stuck_out_tongue:

Kisses
Emőke


#8

Emőke, I’m glad that helped and if I’m ever in Budapest, I’ll let you buy me a beer.

If unticking the box for Use Hardware Acceleration fixed the issue, you may want to check for graphics card driver updates and install them if there are any.

Happy sketching.


#9

Definitely contact me when you come here :smile:
I will check the graphic card thing as well.

I am typical girl, there is no way to do something against it :stuck_out_tongue:

Thank you again.
xx


#10

@Miss25,
Apple updates the drivers automatically, when available, so just make sure your system is up to date…
Click on
Apple in the menu bar >> About This Mac >> Software Update and it should sort you out…

BTW. does the issue return if you now ‘re-check’ Use Hardware Acceleration ?
I have noticed on my macs that toggling it off, then back on, it often seems to work as a reset that allows me to continue using it…

john


#11

Dear John_drivenupthewall :slight_smile:

Thank you for your help.
What rendering software do you use? I am using Indigo… it makes my apple noisy and hot… I would try out something nicer, I am affraid one day my apple will “burn down” :smiley:
I would need a nice rendering software for only interior design stuff… not a big deal but I don t really know which is the best for an apple mac book pro.

Thank you for your time and help.
Emőke


#12

Mine did, Graphics card and battery…
find a ‘Fan Controler’ that lets you set the fan to turn on sooner and it should run quieter and cooler…
I used this one… but got it too late…
avoid running it in a case or on your lap, and use an aluminium stand if possible…

I use ‘Visualizer’ for quick ‘free’ renders and ‘Mitsuba’ for more controlled output…
there are a couple of rendering threads which go into some detail of peoples choices…

john


#13

I think it’s a good sign, a Renderer which doesn’t make your hardware react like this isn’t using all of the resources :wink: