Cropping DWG / DXF in Layout

Hi, is there any method available to crop DWG / DXF in Layout?
Set Clipping Mask is greyed out for these objects, which I have inserted as Model Space, so currently I am just lobbing white rectangles over things I want to hide.

Note: behaviour does not change for DXF downloaded / created in Inkscape, or created from Sketchup

Hi jonnyshield, we currently do not have a way to crop native LayOut entities and that is what the dwg / dxf is converted to when imported.

If you import the dwg / dxf and use the SketchUp model reference the data is place in a viewport just like a regular SketchUp model. You can then set a scale via the SketchUp Model inspector as well as cropping the viewport is need be. Down side as you probably know is that text and dimensions will not come in.

Trent

I know this doesn’t answer your question directly but in addition to what @trent said, you can also import just Paper space viewports into LayOut that are already cropped. Note that this comes in as a ‘scaled drawing’ so it’s editable in LO but doesn’t link back to the CAD file anymore.

Hi both, thanks for the replies - good to know I’m not going crazy.

Eric - I am having issues importing DXF / DWG into paper space, nothing happens when I do this - any ideas?

Rig 2D sketch.dxf (2.0 MB)

johnnyshield, the file you are importing does not have a defined scale in the Paper Space. LayOut needs this information to import the data correctly at the right scale. So in acad or other, define the scale of the Model Space, you can then adjust the viewport to crop the area you would like, save, then import into LayOut.

By default a cad file will have a Model and a Paper Space so LayOut will see that a Paper Space is available to import but if the the viewport does not have a scale defined LayOut will not import it.

Trent

@johnnyshield See gifs below to help explain what @trent described. Create a viewport and scale it in Paper Space. Then import CAD file to LayOut, choosing ‘Paper Space’ from import options. Then explode the group and change the scale if necessary in the ‘Scaled Drawing’ Window. I did not assign a scale so the scales I selected were just for reference and were not correct.