Creating DXFs with true circles for laser cutting


#1

Hello, I’ve been trying to create DXF files for laser cutting. I understand that to create true circles you need to export as a 3D DXF however I am having an issue with dimensions. When I open the DXF in a viewer (Autodesk) all dimensions appear to be scaled into inches then shown as millimeters i.e a 100mm line is displaying as 2540.236mm. Can anyone suggest what I’m doing wrong? Many thanks.


#2

When I open a 2D DXF in Adobe Illustrator the measurements are fine however in Autocad viewer I am having the above issue with dimensions being wrong. Our laser cutting company is getting the same result. Is there perhaps a setting in Sketchup that ensures any exported files contain info regarding the scale?


#3

can you post a sample skp…

it is most likely an export or model setting that’s gone awry,


#4

Which SketchUp version? The last export unit glitches were corrected in the 2016 version, older ones had the Measurement system variable set to imperial units whatever unit you were using in your model. It works correctly for me.

Are you sure that the units in Window menu>Model Info>Units are set correctly and that your model isn’t actually in inches even if you think you are using millimeters? SketchUp uses the units defined there for exports, whereas for importing, it uses the units you specify in the Import Options dialog.

Another possibility is in the import settings in the receiving applications. AutoCad can be set to automatically scale all imported content to units you specify, overriding the settings found in the file.

Anssi


#5

Thank you both for your comments.

See attachment of a sample files.

I am using a trial version of 2016 Pro. Units are set to MM in the Model Info. I am using the web browser version of A360 viewer so I don’t think it offers any option to change import settings.

100mm is showing as 100 inches when opened in the viewer. Any help appreciated.

Test file.skp (98.4 KB)

Test file.dxf (339.7 KB)


#6

Your DXF looks quite OK in AutoCad 2016. Is there possibly a problem in the A360 viewer or the CNC software? Did you import the file into another drawing that uses inches?

You could also try downloading and installing the free DWG Trueview from http://www.autodesk.com/products/dwg/viewers.

Anssi


#7

I’m using a Mac so unfortunately cannot install the desktop version of Trueview. I can’t see why the web version would have an issue with displaying the DXF properly.


#8

Ok, I’ve found a solution which may be of interest. By changing the Decimal units to inches it now exports a 3D DXF that displays with the correct measurements (in mm) in Autodesk A360 viewer.

Can anyone suggest why this works?


#9

There is definitely an error with the measuring functions in Autodesk A360. Millimeters are translated to inches. The odd thing was that when I selected the circle and looked in the Properties, it displayed the right value. I sent an error report to Autodesk.

Anssi


#10

I think you’re right. I’ve tried some old DXFs, which I know are correct, and they too are showing the wrong measurements. I’ve sent them a message too.

I’ll need to check what viewer our laser company is using as they brought up the issue originally.