Create layout

Just getting started with layout. My main purpose is to make work drawings and plans. Now when I “send to layout”, the view that I have from the scene in SU doesn’t shew completely on the frame in layout. I can make it visible bu stretching the frame but somehow, it has a strange behaviour, I can’t always see the logic in it. So fist of all: why is the scene not completely visible when I get the page set up in Layout?


The aspect ratio of the viewport in LayOut is affected by the aspect ratio of the paper. Your SketchUp model window has a different aspect ratio than the paper does. It’s much longer than the paper. Not to worry, though. Select the viewport and drag the edges as needed to show the model the way you want to show it. Before you drag the edges, though, set the scale of the viewport to something that makes sense for the application. With the viewport slected you can set the scale in the SketchUp model panel.

Do you want to print the gray background? If not, edit the style to get rid of the background.

If you share your LO file I can show you more detail.

1 Like

Dave,

here are the files, I just started with the scenes, they are not finished yet, I have to add the measurements. I took some online course in SUCampus already, but only the beginning. I installed also the plugin: “create layout file from scenes”. In the layout file there appeared some guide lines out of the blue.

How do I delete the grey background?

greetings

LO_SM_werktekeningen.layout (1.3 MB)
SKP_SM_tuinhuis-LAST.skp (1.4 MB)

4 Likes

Since you are learning SketchUp, I’m going to suggest that you refrain from using that extension. Learn how this all works by doing it yourself so you have some understanding of what’s going on when you do use the extension.

I opened your SketchUp file from LayOut. When I finished fixing the styles and updating the scenes, I saved the changes in SketchUp and returned to LayOut where those changes were updated automatically.

First let’s deal with the SketchUp model and the style. Go to the Styles panel and make sure you are looking at the In Model styles. Select the style used in the scene and then click the Edit tab.
Screenshot - 7_31_2021 , 7_10_07 AM
The style you have for the scene is set to the Wireframe face style. I changed that to Hidden Line so you’ll have black lines on white background. (Click on the second cube in the row under the Select, Edit, and Mix tabs.)
Screenshot - 7_31_2021 , 7_30_16 AM

Then the background color to white. Click on the color swatch square to the right of Background. and change the color.
Screenshot - 7_31_2021 , 7_30_56 AM

I also changed the Section Fill color to white and set the section cut lines to 1 and turned off Section Planes.
Screenshot - 7_31_2021 , 7_31_19 AM

It wouldn’t hurt to adjust the description to suit. After you make the edits, there will be circular arrows on the style’s thumbnail at the upper left corner which indicates the style has been modified. Click on the thumbnail to save the changes.
Screenshot - 7_31_2021 , 7_39_47 AM
When I opened your SketchUp file I saw a bunch of styles. I applied this Hidden Line style to all but Scene 1 by selecting this style and then right clicking on a scene tab and choosing Select… For Scene 1 I set the background color to white and updated the style. I then purged the unused styles.

I revised the scenes in your model so that the model pretty well fills the model space using Zoom Extents. I find this helps with things such as model alignment in LayOut when you have more than one viewport on a page.

‘Scene1’

‘vooraanzicht structuur’

‘snede verticaal structuur’

Now in LayOut:

Before I made any change to the viewport I reset the Camera section of the SketchUp model panel. In order for this panel to be active you need to have a viewport selected. If the Reset button is displayed and the Camera section’s background is dark gray, camera-related changes made in the scene in SketchUp will not be shown in LayOut. I find that there’s almost never any need to change the Camera settings in a way that causes the Reset button to be displayed.
Screenshot - 7_31_2021 , 7_17_19 AM

The current scale of 1:214471 isn’t very useful so I changed the scale to 1:20. Then, to resize the viewport, select it, grab the edge and drag it. Here I resized the viewport from the center by holding Alt on the PC. I believe it would be Command on the Mac but you should chack that.
VP

Going back to the point about using zoom Extents when setting up the scenes in SketchUp, here’s one of the benefits. After setting up the first viewport (Scale set to 1:50 just for this demo) I copy the viewport and then paste it. Paste is a Paste in Place action in LayOut. Then down arrow key while holding Shift to move the pasted viewport straight down the page. Change to the other scene in the SketchUp model panel and the model in both viewports is perfectly aligned with no other adjustments required. This isn’t an option when your model is randomly located in each scene.
copy VP

This also works across multiple pages. Here I’ve added a page number so you can see when I change pages.
copy VP2

2 Likes

By the way, I cleaned up your SketchUp model a bit. First, I corrected the incorrect tagging of geometry. There wasn’t much which is good.
Screenshot - 7_31_2021 , 8_11_58 AM

Then I purged unused stuff from the model.
Screenshot - 7_31_2021 , 8_12_16 AM

Here’s the resulting LayOut file.
LO_SM_werktekeningen.layout (1.1 MB)

2 Likes

Well thanks a lot once again Dave, I learned a lot again.

1 Like

Thanks Mike. I’ll visit the SU.nl site to learn more!

1 Like

Dave, how did you do that?

Some strange phenomenon happened: When I make a section cut and do Zoon extend, the whole model vanishes, is do cmd Z it doesn’t undo the action. What’s happening?

Not sure if it’s under view or camera, but there’s an Undo camera button

1 Like

It seems there is no Reset button.

Besides that there is the ! symbol that says: object snap…? I can’t change the scale either.

Typically when Zoom Extents makes the model disappear, it’s because there is some entity at a huge distance from the rest of the model. Share the .skp file in its current state so we can see what’s going on. Something has changed since the previous version that I have.

Normally there won’t be a Reset button. If you manually change either of the items in the Camera section, marked in red, or you modify the SketchUp camera in the viewport, the Reset button will appear.
Screenshot - 8_1_2021 , 5_53_40 AM

Where are you seeing that?

Scale will only be an option if the camera is set to Parallel Projection and a standard view is selected for the scene in the SketchUp model. It won’t be available for Perspective views. So for your Scene 1 which shows the model in Perspective view, Scale isn’t available.

Here is the updated version of the SU model, with the scenes completed.
I was still wondering whether what is best: to add the dimensions in SU or LO. I just need them on paper, so LO seems to be most obvious.

SKP_SM_tuinhuis-LAST~~.skp (1.4 MB)

I found out that that it’s when I just made a section cut and the section plane is still visible, so the section plane seems to be have a more or less infinite dimension and the model is then infinitely small. (my guess)

in the right corner below of the viewport:

Schermafbeelding 2021-08-01 om 14.56.23|690x388

in this screenshot:

The scene from where the viewport comes, is in parallel projection. Also there is the ! symbol in yellow triangular both in the list and in the drawing. (?) Moreover, the model is not completeely visible, maybe that has something to do with the the section planes?

I’m not seeing any giant section planes in your model.

The section planes will be sized to encompass the entire space willed by the model. Here I’ve added a cylinder off away from the model. You can see how the section planes have enlarged to include it.

If you are seeing huge section planes, you need to look for entites that are located away from the rest of your model. One option would be to Select all of your shed model, use Edit>Invert Selection, and then hit Delete.

Note that the file you uploaded is a backup of abackup. The tilde (~) in the SketchUp file name rindicates it’s a backup file that SketchUp created. If you open the backup file instead of the original and then SketchUp makes a backup of that, it’ll append another tilde. At this point I suspect you have three different versions of this shed file.

I would add the dimensions in LayOut. You have much better control over how they appear and where they end up on the page.

That means the viewport needs to be updated to match the model. You must have Auto render turned off in the SketchUp Model panel. Tick the box for Auto.
Screenshot - 8_1_2021 , 8_24_15 AM
By the way, that has nothing to do with Object snapping.

It might but the first thing to do is to let the viewport update after ticking the Auto box.

Still have some trouble with updating changes from the SU model. Changes happen on some pages, on others not. Even when I right click and “update from SU model”, it doesn’t.

I was also wondering how I could change the dimensions fixed from inches to MM, it seems that I have to do it every time when I add dimensions, there is nothing in preferences about it.

Share the .layout. My guess without seeing it is you modified the viewports that won’t update. Remember that changes you make to the viewport override the scene properties in the SketchUp model. You also need to make sure you are editing the correct SketchUp file. That is you are editing the one that is actually linked to your LayOut file.

Units and other dimension properties are set in the Dimension Style panel, not in Preferences. You need to make the setting while either the Dimension tool or an existing dimension is selected.
Screenshot - 8_2_2021 , 9_30_23 AM

SKP_SM_tuinhuis-LAST - A4~.layout (1.6 MB)

It’s made with the extension in SU “create layout from scenes”, simply because I se no other way to add new pages and link it to the scenes.

BTW, I don’t like the letter style of the dimensions, way too large and too bold. I don’t see where I can change that.

Is there a way to fix the option mm/inches so I don’t have to select that every time again when I open a LO file?

I also made some changes to the styles of the scenes.