Crashing Sketchup Shop - Help

Hi There!

I’m new to the forum but have been trying out Sketchup for about 6 months. I am on Sketchup Shop and with no experience (just a short online course) am designing my house renovation. My model so far would be full of errors I’m sure, but it does not explain why it crashes all the time. I am now unable to make any change and save it.

I have gone through and purged unused materials. I know it is very heavy so it is probably my graphics card which is listed in my profile.

Is there anything I can do to stop this happening. What is the best upgrade to my computer I need to make considering I am not using this professionally. I just want a model I can use to help my draftsman and tradies understand what I’m trying to achieve.

I have been so frustrated and kept away from it for a few weeks. Have come back and can barely move around without it crashing.

I don’t know how to upload from the web version into this thread.

Please help, as I’m at my wits end.

Thank you

First download the .skp file to your computer. Click the folder icon at the top left and choose Download.

Choose the oldest version, 2017, so more people here will be able to open it.

Then just drag the file to where you type your reply here.

1 Like

And if it is too big to upload here, upload it to a fil sharing service like Dropbox, OneDrive or Google Drive and post a link here.

Hi
Thank you, here is the link to the Google Drive file

There are a number of layers hidden at the moment.

Hope it’s not too much of a mess.

Thanks again,

Katrina

Your model didn’t crash SketchUp Pro free or Google Chrome for me, but you do have a lot of clutter in your model. SketchUp fixed some errors when it opened and then again later.

I purged unused components and materials, this cut the file size to less than half the original.

To speed things up, turn off profiles:
profiles

Change to monochrome mode:
monochrome

Turn off edges:
edges !

You’ll probably not want to leave edges turned off, but it’ll give your computer less work to do while you try and simplify your drawing.

I was using the search to find those settings, click the magnifying class or type ‘?’ then start to type the command. If you’re using Shop, you should be able to edit a style to have the colours you want with profiles and textures turned off.

Go to materials, scroll down to the bottom and click the circular arrows to purge unused materials. Do the same for Components.

You don’t need to clutter up with plants and jars on the shelves until you’re finished drawing the house. Try and move them to another file until you’re finished or at least tag them as ‘clutter’ and hide that tag.

There’s other problems in your model, like the flickering on the floor where you have two planes in the same location. Try the above settings changes to speed it up a bit first before you start fixing those.

If this is easier to work with, here’s a copy of your file that’s been purged:

I haven’t changed anything else. It’s 57MB instead of 134MB.

@McGordon Wow thank you so much! So the problem was the size of the model due to the clutter and mistakes I’ve made in drawing it rather than my computer hardware?

I opened it, moved the roof back to position and it saved!!!

I had been pressing that purge button but didn’t seem to do much.

I will play around with what you’ve suggested and hopefully be able to get in and improve the model.

Thank you once again. I was incredibly frustrated. Grateful for this forum and helpful people :slight_smile:

It didn’t cause any crashes here. Maybe you ran out of memory or something. The clutter shouldn’t make it crash, just slow things down.

Ok thank you :slight_smile: