Crashing after recent Mac OS Update

Running Sketch Up Pro Version 23.1.341, Bought a new Mac Studio last month and the App has been running very well on several projects. Earlier this week the MAC updated to Sonoma 14.3, since then whenever I go into the paint bucket and choose a texture or color the app shuts down. I am now doing everything in my projects and leaving the Paint Bucket until last, the app with crash, then reopen and run fine if I choose paint bucket 1st and use it, its not until I choose another aspect in the app (Push Pull, Offset, Move, Shape etc…) use that and try and go back to choosing a texture that it crashes again. It’s becoming annoying. anyone else having this happen? Is there a fix etc…?

Thanks for listening.

There is no fix. SketchUp and Sonoma are not supported yet. Some people having good luck, others (like me) rolled back to Ventura.

1 Like

I think I found a workaround especially for woodworkers!

Use OCL (OpenCutList) to allocate colors and materials.
Maybe that helps a while.

2 Likes

One of the developers is trying to figure out the reason for the new crashing, in the hope of being able to find a work around.

In the meantime, I am trying to make a low-tech alternative, that would work without any extensions.

Here’s how far I got. Open this file and use the paint bucket’s eyedropper to pick up the material you want to use.

Mac Materials.skp (1.7 MB)

I did finish that model, and wrote a post about the problem here:

2 Likes

I didn’t know I could roll back, Apple use to prevent that vigorously .

Great, will the information regarding a new update that will fix this issue be posted here?
Crashing every time for us at the moment, which is …annoying at the best.

I have just started to evaluate Enscape -but they have a crash situation which — Unfortunately in the meantime, the only way to resolve this issue is not to install the SketchUp 2023.1

I couldn’t find 2023.0 to download…
I did find 2022-0-353-126 which I’m current running due to Enscape…

But one workaround I found regarding this threads issue is to use Enscape material in SketchUp… since for me SketchUp crashes when I try to switch the item on the material dropdown list.

Sonoma 14.3.1 is out. I updated, but still the same…

1 Like

I get the beta versions as well, and 14.4 still has the crashing.

1 Like

I suggest people leave a few words about the situation at apples site. Feedback - macOS - Apple

there´s no personal response but they say they read it.

How did you go back to my latest update on your Mac? It’s annoying. I can’t use the dimension style in layout. It’s frustrating.

Thanks for link. I just sent a response to them.

Here are a couple of links. I had a Time Machine backup, but I also had a weird failure midway through a restore, so it was difficult but I got it done.

You’ll need to decide what makes sense for you. I have Time Machine as well as Carbon Copy Cloner backups. I only lost 2 hours of work before I decided to revert to Ventura.

I looked at that article, and tried the steps with my Time Machine drive attached. There is some worrying language about how the drive you select will get wiped, but in theory restoring from a backup should then reinstate everything.

My Mac had updated straight from 13.6.4 to 14.3, and so I had no option to go back to 14.2. If I had I might have tried that, because colleagues using 14.2 are not getting the crash. I warned everyone here about updating from 14.2.

As I couldn’t go back to 14.2 I skipped the test, because I already know that 13.6.4 didn’t have the problem. For now I need to be on 14.3 anyway, to confirm our own work around, as well as any fix that Apple might do.

Has anyone seen a fix yet?

For me, Sketchup crashes not only when the bucket tool is used but also when I open other windows, such as components.
Can we just have all tabs inside the main view like windows has?

An issue shouldn’t take months to fix when we are paying a premium for the software…

Updating to MacOS 14.4 should fix the materials window related crashes.

1 Like

I have the same issue, I downgraded from Sonoma to Ventura on my mac M2, installed sketchup pro 2023, 23.1.341 and then Enscape 4.0.0.577 and when i try to open Enscape, the Enscape windows pops-up and in less than 5 sec disappears. Very frustrating. I’m waiting to hear back from Enscape…

Did you read the thread? If you truly have the same problem then it is solved.

1 Like