Crash after updating Mac OS X


#1

Hi

I have a problem starting the sketch up program after i have update my Mac OS X .
The program cannot start. It always crash when the sketch up window open.

I cannot run the program now and i need help and advice.

Regards
Daniel


#2

Hi Daniel,

Here’s a good place to start…

You’ll find more information on Mac issues here:
SketchUp Sage Site > Mac Issues

-Geo


#3

same problem,close outliner window seem to be cool for now.


#4

Hi Geo

I have try to repair disk. but it does not work. Should i upgrade to 2014 to run it.

Or how can i fix the problem. When the sketch window open for 2s it crash.

Pls advice what else can i do.

Thank you


#5

The word seems to be that Mac OS X Yosemite changes some aspects of how fonts are handled, and this causes crashes in SketchUp, especially when the outliner is open. Hopefully there will be a patch soon to fix this!


#6

Please post crash logs to bugsplat and I’ll take a look, or grab the head of them.


#7

OK, I grabbed the Fonts crash. If you have another one, please let me know. Thanks.


#8

So are you running 8 or 2013? My guess is it has more to do with some preference or document. You could try moving aside your preferences: quit SketchUp, rename the file in ~/Library/Preferences/com.sketchup.SketchUp.plist (that’s for 2013) to something else, then restart SketchUp.

If it’s a previously opened file, hold down shift when you launch SketchUp, and see if that helps.


#9

hi

Im using sketch up 8. everything is find now. my crash is cause by podium. And i have fix it already.

thanks for help.


#10

Hi Bary

oops My fonts still crash.

pls help

This


How soon till sketchup works with yosemite
#11

OK, I found a workaround, but it’s a bit of a pain. First, the workaround, then an explanation:

The fonts panel is crashing SketchUp on Yosemite, so you need to rename the font panel. If you’ve installed to default locations on Mac in English, and you’ve opened SketchUp before, these commands will work.

  1. Quit SketchUp
  2. Open /Applications/Utilities/Terminal.app and paste in these commands, and hit enter:

SketchUp 2014:
mv /Applications/SketchUp\ 2014/SketchUp.app/Contents/Resources/English.lproj/SkpFontPanel.nib /Applications/SketchUp\ 2014/SketchUp.app/Contents/Resources/English.lproj/HIDESkpFontPanel.nib

SketchUp 2013:
mv /Applications/SketchUp\ 2013/SketchUp.app/Contents/Resources/English.lproj/SkpFontPanel.nib /Applications/SketchUp\ 2013/SketchUp.app/Contents/Resources/English.lproj/HIDESkpFontPanel.nib

SketchUp 8:
mv /Applications/Google\ SketchUp\ 8/SketchUp.app/Contents/Resources/English.lproj/SkpFontPanel.nib /Applications/Google\ SketchUp\ 8/SketchUp.app/Contents/Resources/English.lproj/HIDESkpFontPanel.nib

Step Number 3: Open SketchUp. You wont be able to set fonts, but it will keep SketchUp from crashing. If you need to set fonts for 3D Text, I’ll type out how to do that in a future thread - I wanted to post this right away in case someone is stuck.

============================================================
Explanation: SketchUp’s font panel is crashing on Yosemite. We’re renaming it, so when SketchUp starts again, it tries to load it, can’t, and will bring up Yosemite’s font panel. The connections to that font panel don’t exist, so it’s not going to list fonts or give you the ability to change anything. But it wont crash SketchUp. We’re working on better ways of doing this, but we wanted to put this out there ASAP. Stay tuned.


Should I upgrade to OS X Yosemite?
OS X Yosemite testers?
#12

For non-English Yosemite users: change the “English.lproj” in the commands listed above, to your Apple Language. For example:
German = "Dutch.lproj"
French = "French.lproj"
Chinese = “zh_CN.lproj” or "zh_TW.lproj"
etc…


#13

OK, so if you do the commands above, the font panel is no longer hooked up to SketchUp. So how can you change text settings? Answer - you can change the SketchUp defaults for 3D Text, but you wont be able to change the per-model text (see Window->Model Info->Text for the per-model text settings for Screen Text and Leader Text). To do that, you’ll have to have a template that has the settings you want if they’re different from our templates.

How to set 3D Text defaults:

You can see your current 3D Text defaults by opening Terminal.app and typing:

defaults read com.sketchup.SketchUp.2014 ThreeDText

You’ll see something like
ThreeDText = {
Align = 0;
Bold = 0;
Extruded = 1;
Extrusion = 1;
FaceName = Tahoma;
Filled = 1;
Height = 10;
Italic = 1;
};

If you DON’T see that, open SketchUp, Tools->3D Text, and change something - center the text (for example), then quit SketchUp and try that command again. You should get values.

You can use a Mac program called PListBuddy to change the values:

Example - in 2014, change my 3D Text Font to Times (replace YOUR_NAME with your user name):

/usr/libexec/PlistBuddy -c “set :ThreeDText:“FaceName” Times” “/Users/YOUR_NAME/Library/Preferences/com.sketchup.SketchUp.2014.plist”

Example - in 2014, change my 3D Text Height to 24 inches:

/usr/libexec/PlistBuddy -c “set :ThreeDText:“Height” 24” “/Users/YOUR_NAME/Library/Preferences/com.sketchup.SketchUp.2014.plist”

I hope that’s enough workarounds for you to be able to use SketchUp on Yosemite. Thanks.

Barry


#14

crickets…Did this help anyone out there? chirp, chirp…


#15

I liked all the posts. Does that help? :smile:


#17

You did read my workaround, above your post, before you posted this? To warn every user of SketchUp about possible Yosemite issues would probably put us in most people’s spam folder.

-b


#18

Updated. Yosemite, SU14, NO font or outliner problems. On both machines.
Using french version.
Maybe disabling a lot of useless fonts in the font book would kelp ?


#19

Hi irbc88. I run Podium and my SKP8 is crashing. I don’t seem to have any preferences to delete and am still crashing. How did you discover and repair the podium issue?
Thanks
Justin


#20

Does this workaround solve the problem of Outliner crashing Sketchup on Yosemite?


#21

Hi Justin
Sorry for the late reply

What did was to uninstall podium 8
And install the ( SU8_podium_2_17992.pkg)

And everything is back to normal now.

As for the ( SU8_podium_V2_18_940_x86.pkg)This has cause it to crash.

dan