Corrupted / Distorted Model Display

layers
layer0

#1

New to Sketchup Make here. Was doing some modeling of house features and run into problems with the model displaying weirdly after some amount of time/saving. So I start with a floorplan (jpeg), import that, scale it up, and then model. I’m trying to keep everything on layers as well as grouped as I do this. For instance, modeling screened in porch: model concrete pad (group it), model brick surround (group it), model porch-adjoining walls of house (both interior walls and exterior brick - group each). And for each of these groups I add a layer and assign them to their respective layer. This works fine for a long time, as I’m modeling, turning layers on and off. But it seems after I save and reload the model is displayed in weird ways. Turning layers on and off doesn’t work as expected. As an example, if I turn off all layers I would expect to see nothing. But when I do this I still see a wireframe of every piece of the model. Zooming/panning shows weird display issues as well: faces disappear to show wireframe, etc.

I’ve tried opening this model on a completely different machine and get same results, so I don’t think it is hardware/graphic card related. I am sure I am doing something wrong as I ran into this same issue on my first attempt and started over with this new model. This is frustrating as I’ve spent a lot of time modelling only to end up with a corrupt end product.

Any help would be greatly appreciated!


#2

If you can upload a sample model we can say with more certainty, but as a guess I would surmise that you have edges and faces associated with other than layer0. If I’m right, yours is an example of how violating this advice can lead to insanity! If I’m wrong, I’ll need to see a model to do a real diagnosis.


#3

Post the model if you can - it is not immediately obvious what is going on here. Is your “Show hidden geometry” turned on?

Anssi


#4

Thanks for the quick response guys. Model attached. Show hidden geometry is off.BackDetail.skp (775.5 KB)


#5

Also please note that the grouping is not as it was. I exploded everything to see if that helped.


#6

#7

The only thing I can see wrong with your model other than the lack of groups which you mentioned is that not all the edges and faces are on Layer 0 as they should be. That could have happened when exploding the groups, though.


#8

The model you posted indeed violates the “edges and faces on layer0” guidance. There are numerous cases in which a face is associated with one layer and its edges are associated with layer0. This causes the face to disappear when you hide that layer but its edges to remain.

Edit: @DaveR I think exploding groups would have associated all the contents to the group’s layer, not selectively associated the faces but not the edges. It seems more likely this was due to the way entities were selected while assigning layers to them.


#9

You’re right. I didn’t go into detail looking at individual edges and faces. I selected all of the geometry and saw that the Layers box in Entity Info was blank which indicates the selection set is on more than one layer.

@tslassit, Steve’s point about violating the rule of keeping edges and faces on Layer 0 at all time would easily create models that appear to be corrupted. They are repairable so not a lost cause.


#10

So I selected EVERYTHING and put it all on layer0. So what is correct way to isolate pieces of the design to layers? Let’s say I start over. Draw concrete pad. Just a rectangle on ground. Do I group then? When I pull it up the new faces/edges will remain grouped? At that point can I assign to a new layer?


#11

Make a group of the object and assign the group to a layer.

Layers do not provide any separation between entities in SketchUp. They only control visibility. Groups and components provide separation.

See this: http://help.sketchup.com/en/article/3000122


#12

Pretty much yes to all of your questions. You can create a group or component as soon as you have some geometry that will belong to that “context”. Even a single edge will do. Then you open the group/component for edit and add the rest of the content, e.g. by pushpulling your slab to thickness. Whatever you draw while a component or group is open for edit will automatically go into that same context, it will not “leak” out. You can associate a group or component with a layer at any point after it is created. This affects only a specific instance (e.g. if a component, other instances can use other layers) and has no effect on the contents of the instance. When you hide a group or component instance by any means (explicit hide or hidden layer) all of the contents are hidden regardless of what layer they use.


#13

So I restarted a bit: started with 2d outline of pieces against floorplan (concrete pad, walls, etc). Each time I explicitly grouped the entity immediately after creation. After creating several groups I the edited each group and pulled them all up, individually, to 13". Now my model view is not correct, corrupted, etc (much like before). Everything should be on Layer0 as there are no other layers. I feel like I did it correctly this time but apparently not. New model attached.BackDetail_NEW2.skp (667.8 KB)


#14

What’s “not correct, corrupted, etc.”? Maybe you could describe what doesn’t look right or show us a screen shot. It looks fine to me as far as it goes…

What is it you plan to do with this model? Do you need to divide the walls up into separate groups as you have? I would be inclined to draw the perimeter walls of the house as a single group. Don’t leave gaps for windows. Add them later by editing the walls.


#15

Freshly opening the model, things look ok. Once I select anything (everything in groups at the moment) the display gets wonky - faces disappear, move, ghost somewhere else, etc. Attached are 3 screens: 1) fresh open 2) select the face of one component 3) select a face of another component.

I have tried forcing the display adapter for sketchup to both the Intel integrated and Nvidia dedicated and behavior is same. Interestingly I did open this model on a different machine and played around for a minute and did not see this behavior. I need more time on that machine though to confirm no problems there.


#16

It’s not a problem with your model. It looks like you have a problem with the graphics drivers.

I see this when I select the various groups. Everything looks normal.


#17

Thanks for confirmation! Good to know I did do things right this time.


#18

You just need some hardware that does things right, too. :wink:


#19

Interestingly, I uninstalled an old 2015 sketchup (I was still using 2017 for this effort), installed latest 2017 (I guess there was a recent update) and things are looking good.


#20

I agree with Dave. Simply selecting groups or component instances should not hide or “ghost” anything else.

However, be aware that there are some model specific display settings whilst within the edit context of groups and components, for hiding or fading similar components, or the entire rest of the model. (This helps to remove background “clutter” when your trying to concentrate on only the “local” entities.)

The control settings are on the “Components” panel of the “Model Info” dialog.[quote=“tslassit, post:19, topic:40246”]
… installed latest 2017 (I guess there was a recent update) and things are looking good.
[/quote]

Yes 17.2 was just released February 15th, 2017.