Copy-Paste to different files causes misalignment

I have been using Sketchup for 15 years and have always copied and pasted from one file to another, and in each file the copied elements end up in the exact same place file to file. This is especially helpful with large models by allowing you to work with smaller segments in separate files, then simply copy the modified object back into the master model. I always purge the master model of components before copying the edited object back in, and, if textures or layer names have been modified, I’ll purge any of those that are unused in the master model too.
On more complex models with lots of components, I will create a reference register mark that allows quick verification that I’m pasting to the proper place and that I have not accidently moved or rotated something (Sketchup’s easy editing interface takes constant discipline to not inadvertently modify something…) I create a lot of my 2D work in AutoCAD, and scaled drawings and registers even transfer easily between the two programs.

My latest project’s site model (the master model) is quite large and consists of a main house and an ADU/cottage. The house is divided into three files and the cottage is a separate file. All the separate files have their models in the same location relative to the default axis. Within those models, the axis is re-set relative to the object being worked on. When I copy the various house parts back into the model, they all are shifted to various degrees by no more than 3/8".
I’ve tried combining all of the house’s components into one model file, purged all components including the registration mark, copied out the master file registration mark along with parts of the foundation to align the 1st floor to (the house’s foundation stays in the master file with the site topography and is edited there), then aligned everything perfectly, then copied all three perfectly aligned house components back into the master file together, and they all still skew separately.
This is the house file - all registration marks and building components in their proper place.

This is the misalignment after pasting the house back into the site (master) file.

This is the site without the house - the foundation, cottage, landscaping, etc. all copy and paste without getting out of alignment.

Has this topic come up before, or does someone have an idea what’s causing this? I had a similar problem with AutoCAD a few years ago, and one of AutoCAD’s help staff said it was a known problem and not to use windows copy (ctl.+ C) and paste between files for vector elements, and instead used copybase. That solved the problem and I have an macro with keyboard shortcut that copies from base world UCS 0,0,0 and then another macro that pastes to 0,0,0. Sketchup, for all it’s highlights, does not allow that kind of user custom control.

What version of SketchUp are you using?

If you are pasting into the model are the global axes in the exact same location between models? Right click on the axes and choose Reset on both sides. If pasting inside a compoennt, are its axes in the exact same relative location/orientation as in the original?

Yes, I’ve reset the house model and and master file to default before copying and pasting. Within the three house components, their axis are set relative to their geometry.

I’m using the latest version of Sketchup Pro.

It would be helpful if you could share example files that illustrate this.

Please complete your forum profile.

DaveR, I assume you are asking for “example files” that illustrate the misalignment problems? This file is huge - is there a limit to file sizes that can be posted - so I’ll see see if parring it down to just a few objects causes the same problem.
I should point out that the registration marks make it easy to realign the model, but the registration marks seem to be off from their respective house components too after copying. I’ll do some experimenting.

There is a file size limitation of about 15 or 16 Mb.

What happens if you copy and paste the registration mark into a new file with perhaps just one component in it? Is there still the same misalignment?

Out of curiosity, if you right click on the registration mark component is Scale Definition available?

I’m curious, you have said paste many times but never said paste in place.

1 Like

Scale Definition is greyed - I don’t know what it’s for. Is that important? I use Sketchup entirely for illustration, so I’ve never once thought about scale for any models I’ve created.

Box, yes Ctl. V to paste.

Then probably not a thing.

I didn’t catch that. If you want something to be in the same spot relative to the global origins, you should be using Paste in place. Not Paste. Ctrl+V Paste means the object is pasted where you click in the destination model not necessarily where you actually want it.

DaveR, You are correct - I use Ctl. B. That usually works for getting objects in the exact same place copying from file to file.

This is getting confusing. So you are using Paste in place and not Paste as you indicated in your original and subsequent posts?

And what happens if you try to use Paste in place into a simple model with only one component?

Yes I’m using paste in place - as far as I know, that is the only way to get an object to to same place. I actually had to look at the keyboard as I did the action to see what the key is use with control to paste in place - B. Fortunately, I don’t often have to describe how I’m using most software, so, when a problem does arise, I struggle with terminology in general.

You should only have to place the building into the site once. From that point forward you simply would be reloading the building, since it should be inserted into the site as a component. Doing this method allows you to edit the building model outside of the large site model for much faster edits, and you do t have to worry about alignment again.


Sonder, that’s like AutoCAD Xrefs. How do you link the objects?

In its most basic form you create the section of the model you want to work on as a component and use Save as on the component to save it as a model file. You can then open and edit and save that file. Then go back to the master file and use the Reload option to update the component.



I’ll second the recommendation with a little added elaboration for clarity in case it wasn’t obvious: When you do it this way, you don’t need Paste in Place anymore to remember where the building goes, so you just model the building in it’s own file, located near the origin, and aligned to natural axes in a way that makes sense for modeling the building. When you make the building into a component, position the component axes in a meaningful place for you and working with it. Once the building is positioned properly in the site the first time, the component axes are the insertion point and what remembers where the updates go when you reload them there after.

I’ve tried several different experiments to see if there is a way to get the model into another file without it spontaneously changing, and all end up distorting the model. The problem appears to be directly associated with the original house model and not the site model per say. The house components were consistently expanded about 3/16" to 5/16" when placed in the site model and elsewhere. Importing them into a new file instead of pasting also made no difference.

As Sonder suggested, I reloaded the house components into the master file instead of copy and paste. Unfortunately, the distortions remained. However, strangely, the model in the house file then became distorted to the same degree as in the master file. The foundation level has never distorted, though it is very small in size and has no solids or components within it.

In the end I copied the foundation from the master to the house file and adjusted it to fit the distorted first floor components. I also repositioned the register mark distortions in the house file back to the master file position.

Next, I reloaded the house in the master file, and I cannot detect any further distortions in the house. They may be there, but can’t see them and even with white back surfaces turned on the joints appear tight. However, two of the three wing’s register marks are now just slightly distorted. It’s so small Sketchup’s measure tool can’t measure it, but I estimate it is somewhere around 1/64".

Here’s a closeup of the register mark center. Two of the wings registration marks shifted in one direction only this time and by the same amount.

This is a presentation model and, as long as there are not substantial gaps between the 1st floor and the foundation level, the model will be more than good enough, though I love to know why the distortions are occurring.

In the past, I’ve had model elements get out of whack, and I’ve always assumed it was my doing. I’m sure there are some super perfectionists out there who never inadvertently erase, move, or even rotate something, but part of Sketchup’s ease of use is the fact that it’s so easy to manipulate and modify things, and with this ease comes certain risks. I frequently create both very small and very large components in their own files, then copy them into a larger model file. Days later, I’ll occasionally see a small gap or overlap that was not there originally, and now I wonder if this copy-paste distortion happens frequently and I was never aware that some times I did not cause the problem inadvertently myself.

This design is unusual for me in that it has three separate wings all at differing angles to the default axis. None of the three wings axes currently align with the axis in the site model, so it has created special challenges and it makes me wonder if those rotated axis within the wing components are contributing to the distortions some how. However, this small bit of distortion is trivial compared to the constant diligence it took with this model to keep groups solid so that I could subtract and add elements at the junctions of the different wing angles and it was both particularly important and more challenging than normal. As usual, I ended up with several important groups that I can’t for the life of me determine where the fault is that will not allow them to be solid…
Fortunately, my client has not asked for any major changes and none at the roof level!

Where is the actual SketchUp document Axis relative to your model? I can’t see it in any of those
It’s not uncommon for DWGs to end up with the drawing a long way from SketchUp Axis - this reduces precision.

1 Like

Adam, I’m not sure what you mean by DWGs - are you talking about AutoCAD files? Below is a snapshot of the entire site with adjacent lots, so, yes, I am 260’ from the origin to the nearest edge of the house. The site was the first model created and, as these things go, there have been a lot of iterations of house and cottage locations.

If Sketchup does care about adjacency to the default origin, then I’ll adjust the next project’s model to keep the primary building model close to the center. Is this a known issue with Sketchup?

I went back to earlier saved house models and site models and, both copying and pasting and reloading the component won’t reproduce the error - I cannot get the component misalignment to reoccur with older models. Makes me think it was something that has recently occurred in the model.
Unfortunately, I did not save yesterdays versions before the distortions and have made too many updates to revert to the previous models. The model and the foundation will just be a fraction bigger from here on.

I look at Sketchup as a fuzzy program - in AutoCAD and Revit, you mostly can’t help but be extremely accurate. At the architecture firm where I work, we exclusively use Revit and AutoCAD and do zero single family residential work and this is a side job. I’m not proficient at Revit and drafting is not currently part of job role, so I use Sketchup at home. I love Sketchup’s ease of use for maneuvering around the model while you are in the middle of functions, and when I’m in Revit or AutoCAD, I often think why can’t they imitate Sketchup’s 3D navigation system - it’s just a bit more intuitive and requires no extra commands. Sketchup falls down miserably on autosnap, and it can be a real productivity impediment and is the thing that causes me the most errors. With Autodesk products, you can transparently use snap overrides and I have them programed into my keyboard for single key calls (yes, everyone should have a programable keyboard!).

So I’m saying uncle on this one. I will return to the forum if I get any clues as to causes in the future.

Thanks for the feedback from those who responded and especially the reload function - however, its apparent that does not cure the problem.