Constant Slowdowns! Not Responding on a decently high spec system


#1

Hi all,

I have 2 PC’s a laptop and a desktop. The desktop having an i5 4570,12gb Ram and no dedicated gpu. While the laptop is an i7 8750H, GTX 1050 4GB and 8GB ram. On both systems SketchUtanp 2018 is so slow. SketchUp constantly crashes. The model itself is not too complex but relatively complex. It is unbearable. I cannot copy and paste, cannot even rotate or do anything without my laptop lagging. Do you have any advice? I read about the purge thing, I tried it with little to no difference. And yes I am using the dedicated GPU and not the Intel GPU. Attached is a image of my model


#2

what does “Window > Model Information > Statistic > Entire Model” say?


#3

image

See attached


#4

Also my RAM usage is quite high at 80% roughly so I do think RAM is the bottleneck in my system


#5

tick “Show nested Components” too.


#6

until RAM is filled up this doesn’t harm to much, close other memory consuming applications (e.g. image/video editors) during modeling.

any memory-hogging plugins installed, e.g. render extensions?

do you use a 3Dconnexion Space Mouse device?


#7

Given what little we know about the model in question, about all one can do is suggest you read more.


Tick … Show nested components
Then, post a screenshot of the upper and lower portions of Model Info - Statistics

Better still, share the model file.


#8

I doubt it is the cause of your issue, but do you really need all those Guide Points (9138 shown in statistics)? Guides and Guide Points are normally temporary aids while drawing things, not permanent content of the model. Once geometry is drawn, the inference snaps are usually better than Guides or Guide Points. Good practice is to delete Guides (Edit->Delete Guides) as soon as they are not essential to what you are doing right now. It is easy enough to recreate them later if you encounter some operation that can’t be handled using inferences.


#9

additionally:

• SketchUp Help Center: Improving Performance


#10

You mention you are running on the dedicated GPU, not the Intel one. Unfortunately, it seems that most dedicated laptop GPU’s share the workload with the Intel gpu. I have been discussing this with NVIDIA recently - the Intel gpu runs the laptop monitor and the dedicated GPU runs the 3D software. This is called an Optimus system.
I have a similar machine and the best work around have found is to use an older NVIDIA driver (would vary with GPU) and you may want to check with the laptop manufacturer and download their Intel gpu driver/chipset driver.
Another thing you can do is check the PhysX page of your NVIDIA control panel and see what gpu is prioritized there.

What are Optimus ‘IGP displays’ and ‘GPU displays’.pdf (106.9 KB)


#11

and plug your notebook to AC at least for testing purposes sothat power saving mechanisms don’t throttle CPU/GPU.


#12

Here you goCapture Capture1


#13

Yup plugged into the mains and am on ‘Best Performance’


#14

Ah yes, this Optimus system is used to save power. I don’t think an older NVIDIA driver would necessarily help performance would it? Which would you recommend for a GTX1050? I went into PhysX settings it was the Intel GPU so switched it over to the GTX1050. I know the GPU is active as on later drivers there is a notification in the hidden icons/tray which shows you when the dedicated GPU is active.I don’t know if it is the processor as it takes forever to copy, rotate and etc due to how big the file is.


#15

Deleted! This seemed to improve performance quite a bit but not too fluid as I would expect from a machine of this calibre. Could it be due to this being a consumer GTX instead of a professional Quadro? It takes forever to copy the entire complex and just isn’t smooth. Maybe CPU due to copying? But this i7 is one of the best mobile CPUs due to being a 2.2GHz turbo boosting up to 4.1GHz 6 core machine. I just don’t understand how slow it is.


#16

Posted the screenshot and attached is the file https://drive.google.com/file/d/1eIpwTY7Wa6HR8Opvdl7mcQkG2Fq55Bcd/view?usp=sharing


#17

LOAD
Your model loaded in 1min 4 sec on my laptop - how does that compare with your laptop? It was unusually laggy for copy paste too, which seems a bit model related.

SPECS
My specs are a bit old and average at best i5 2.5ghz, 16GB ram, NVIDIA 540M 1GB. The difference may be the drive - I am on a Samsung 850 1TB EVO SSD makes a huge difference to overall efficiency.

DRIVER
I couldn’t recommend for a 1070 - it was just trial and error for me, partially based on when the PC was built. I upgraded from WIN 7 to 10, so that has likely created driver issues running it on an older machine.

TASK MGR
Just to confirm details of how your dedicated GPU is performing during load and modeling process with SU, you can set up the NVIDIA GPU in the details tab it will then appear in the performance tab also). It may help most if you end up talking to NVIDIA support.


#18

It took 18 seconds on my laptop but since I am on the trial I have the loading screen but including all that it is 18 seconds.

Does RAM help? Is 8GB enough? I feel like maybe if I upgrade to 24GB it would drastically improve. But this may be down the line when I am reaching 90%+ usage.

Driver wise, don’t really have the time to go through and find a good driver for the 1050.

For Task Manager, do you mean the performance? On processes I have GPU 1 running for SketchUp. While GPU 0 for other activities. GPU 1 being dedicated and GPU 0 being integrated


#19

You have some 80mb of raw geometry, that is going to lag no matter what computer you use.
You need to learn about groups and components.
Here I have roughly remade your model using components. This is not meant as an accurate copy, I have simply selected the two parts of the geometry that repeat and used them as components then arrayed them roughly like you did.
Giving a file size of just 456 kb.
ComponentsBox.skp (456.6 KB)


#20

As @Box demonstrated, one’s modeling technique has a tremendous impact upon model performance.
No amount of fancy hardware can compensate for poor technique.

Many new users suffer performance issues by unwittingly selecting the Architectural Design Style.
It is a notorious poor performer.

Speeding Up Rendering with Fast Styles — SketchUp Help
https://help.sketchup.com/en/sketchup/speeding-rendering-fast-styles