Constant BugSplat

Greetings,

I have been a SketchUp user and developer for several years, but last year, my older laptop was so sluggish because SketchUp wouldn’t work with the graphics card that was in my laptop, and I couldn’t replace it. So I purchased another laptop an LG Gram 17. Now SketchUp tells me that there are multiple graphics card on my system, but I have no way of knowing how to access them. The documentation does not help.

I just started using Sketchup again (Sketchup Pro 2021), this past week and after a few minutes SPLAT!! So I tried again, and I was just drawing lines for a floor plan, and again SPLAT!!! I tried to Import an item from the Warehouse, and saved it to my disk. But when I go to the Import Option to get the item I just saved…SPLAT!!

I have invested a lot of time and money into SketchUp over the last several years, building my own extensions, but these latest versions are killing me. SketchUp Pro 2021 is possibly the WORSE version because it’s so unreliable, that if I can’t a get a resolution within the next day or two I’m out searching for a new solution. I AM SO DISAPPOINTED by these new versions, because it was running great on my older laptop until I needed to move to a new graphics card.

Can anyone help me, or am I going to be forced to look for another solution?

Scott.

What are the graphics cards your computer supposedly has? Did you check with the makers of the graphics card to get the latest versions of their drivers?

Are you submitting the Bug Splat reports with your e-mail address so they can be identified and looked into?

When you installed SketchUp did you do that correctly? It requires right clicking on the downloaded installer and choosing Run as administrator. If you didn’t do that do it now and repair the installation.

Please complete your profile. It only says you are using Windows 8.

When did you install SketchUp 2021?

We’ll try to help you but you have to meet us halfway and give us some information to work with.

As far as the graphics cards are concerned, right-click on the desktop and look for something similar to “Nvidia Control Panel”.
I probably could have given a better answer had your profile been updated.

1 Like

All the laptops I found with the name had only integrated Intel graphics. Might be that I didn’t look hard enough.

You have a subscription, have you thought about trying SketchUp 2022, see if that works better?

I sent a link to colleagues, to your 6 bugsplats from today. Hopefully someone will have a suggestion to make.

This is important. When you take a new laptop out of its box the graphics driver installed is often more than a year old, of a version that was current when the laptop factory first created the model. No one installs updates on computers inside containers or in storage waiting for a buyer.

2 Likes

To all that are viewing this challenge of mine. Here’s the response I sent to SketchUp support.

I was continuing to experiment with certain things, and here’s what I have come up with.

I first started using the new Version of SketchUp recently, because I was involved with other development activities with another type outside of SketchUp. I then opened SketchUp and started experimenting with the new version, and after drawing 5 lines into the new document, I got a BugSplat error and it kicked me out. Retried again, and it started working without a problem.

Then I loaded 3 extensions that I had previously developed and installed and they were working perfectly from the other version. Once loaded, they functioned appropriately with a few minor inconsistencies that could probably be solved within the extension methods. But they were working and the information they were generating was correct.

Then I needed to import an object from the Warehouse. I developed a habit of always download to a special folder for all of Warehouse imports so that I can use them on multiple projects. The downloads worked perfectly and I was able to save the object(s) to my Warehouse folder.

Then I tried to import the Warehouse object into the model. And that’s when I got the BugSplat error. That happened consistently each time I tried.

So my thought was maybe, just maybe, it might have something to do with my extensions. So I disabled my extensions, and tried to import the object and it worked!! However, that left me with the concern that I would have to do something different to my extensions. That was a lot of code to work through and I wasn’t thrilled with the idea.

The next step was to Enable the Extensions, which I did, and tried the import utility and it also worked properly, after my extensions were Enabled. This was really confusing to me, but it appears that both the extensions and my Import options are working just fine, and I haven’t experienced a BugSplat since then.

I also tried the Preferences, OpenGL and it was set to 0x for the Mutlisampling anit-aliasing. I changed it to 4x, and there was no difference in the results.

However, I’m still getting the launch message about the multi graphics card issue for my computer when I first open up SketchUp. I looked on my Devices within my System Setup and I only have a single Graphics card, which is the “Intel(R) Iris(R) Xe Graphics.”

So at this point, it seems that everything is working properly except for SketchUp sensing multiple graphics cards when I only have the one.

Summary of actions taken and event results.

Started with SketchUp - no custom extensions loaded - 5 lines drawn - **** BugSplat. ****
Tried again -
multiple lines drawn, created a group, saved file - No BugSplat.
Loaded my custom Extensions (which worked on previous version)
created objects, saved files, everything worked fine - No BugSplat.
went to Import object, IMMEDIATELY **** BugSplat ***
Entered SketchUp again, with Extensions loaded and enabled
first action taken - Selected Import, IMMEDIATELY **** BugSplat *****
Entered SketchUp again,
first action taken, Disabled all my custom Extensions, (didn’t remove them just Disabled them)
second action Import, the file selector was displayed and I was able to select .skp file to import object - No BugSplat
third action taken, Enabled my custom Extensions
fourth action Import, the file selector was displayed and I was able to select .skp file to import object - No BugSplat.

Apparently, everything now seems to working properly, but trying to work through these steps was a little frustrating to say the least. I’m hoping that everything is initialize properly and hope the summary I provided might assist in trying to determine the cause, which might happen to others.

I appreciate all who have tried to devote a little time to resolve this issue for me, and I’m hoping that by following the steps that I went through resolved the issue.

Thanks again,

Scott.

Thanks to everyone for your responses.

In November 2021, I purchased an LG Gram 17, specifically to run SketchUp. I’m running Windows 11 Home, and the Graphics Card is Intel Iris Xe Graphics. I’ve checked with Intel and I’m up to date on all the drivers. I’ve checked the .NET Frameworks and have version 4.8 installed.

I am sending the BugSplats to Sketchup Support, and one of their responses is that it has something to do with the graphics drivers, and yet I’m up to date on all of the Drivers from Intel.

I reviewed the product prior to purchasing the laptop and of all of the articles this one stood out the most.

LG Gram was one of the computer that was recommended.

I have been running Sketchup for the last several days, and continue to get a BugSplat, but not at the same time, even after repeating the same steps I did before. It seems to be arbitrary in when it decides to crash on me. I’ve tried running with and without my extensions enabled, and I get the same results.

When I enter SketchUp, SketchUp indicates that I have multiple graphics cards, and suggests I select the AMD/NVIDIA cards. Neither of which I have on my system. I only have the single Intel Iris Xe Graphics that’s listed on the System Devices under Display.

Am I the only one in the world that is experiencing this problem. All of the applications on the computer are operating just fine, as they were also doing on my previous laptop. I’m only experiencing this situation with Sketchup. This is so frustrating that I can’t even complete one model before it crashes on me. I’M NOT A HAPPY CAMPER to say the least, and I’m not sure how to get this whole graphics card issue resolved.

I appreciate the time you elected to spend to assist me. I am grateful. I’m just frustrated that I can’t seem to find the solution.

Scott.

By the way DaveR, I found the area where I needed to update my profile and did so as you suggested. Thanks,
Scott.

1 Like

Thanks for updating your profile.

This is an integrated graphics card. Integrated graphics cards have nevewr been recommended for SketchUp. This is partly because they have to share resources with the CPU. I don’t see that Colin has looked up your Bug Splats so I don’t know if they are related to the GPU but it could be related.

It’s unfortunate that you didn’t get a computer with an appropriate graphics card. Historically Nvidia graphics cards, especially the GeForece and GTX-series cards have been most robust for OpenGL support.

One thing to check:
Go to the Window menu>Preferences>OpenGL dialog, and if the “Use Fast Feedback” box is checked, uncheck it and restart SketchUp.

The OpenGL option is disabled and is unchecked with 0x Multisample anti-aliasing.