Components not showing up in Outliner

I’m having trouble with the components I make not showing up in the outliner, If I make the object a group it shows up in the outliner. Older drawings have components that I’ve made earlier show up when I open the old file but I cannot make new components show up in outliner.
Sketchup thinks I have made the component because when I try to name the same component again it tells me I already have a component by that name.
Do I have a setting that is turned off?
Thanks
JSM

It would help if you share the .skp file so we can see what you’ve got.

Wild hair guess, though:

Do you have the box for Replace selection with component checked in the Create Component window? If you don’t, the component will be created and show up in the In Model Components but won’t be present in the model space. And if it’s not present in the model space there’s no reason for it to show in Outliner.

That was it!
Thank you!

Why is that even an option?
What reason would one have to not replace selection with component?

You might want to create variations, for instance.

1 Like

As @Anssi wrote, you might want to make a number of components each slightly different than the rest. You might also want to make a component of a small section of a larger bit of geometry but don’t want to divide up that larger bit. For example, souppose you have a crown molding running around the inside of a room. You could create it with a profile using Follow Me and have the entire run of molding as a single object. Then you might want to make a component of one section of that molding to use elsewhere in your model. You can select the section of molding, create a component without replacing the selection. Then go to the Components panel and bring out an instance of the molding component.