Components Attributes Window doesn't update properly

#1

MacBook Pro running Mojave 10.14.2 and SU Pro 10.1.1180. I have seen various forms of this issue over the years, but it finally got to the point where I decided to ask for help. The frustrating part to this is that I have created similar dynamic components before and if I keep playing around with it, eventually it works.

I am working on a door so that it opens/closes with a click of the interact tool. The door has several nested components (rails, stiles, molding, etc.) and the one that is of interest is the glass and the glass frame, which are in a component called “glass and frame” in the model. To make it dynamic, I want to toggle RotZ between -80 and 0. So, I have these three entries:

  1. In the RotZ entry field, I typed in: “=20.5x36 casement glass and frame!Rotate*-80” with no quotes.
  2. I created a custom variable named “Rotate” with no quotes.
  3. In the On Click filed, I entered “Animate(“Rotate”, 1, 0)” with no surrounding quotes (the quotes around Rotate are required).

This should result in a dynamic component that opens and closes. In fact, this is the end result that does eventually work. But along the way, while entering this information, SU complains with this error message: “ERROR: Invalid entity to animate (“Rotate”)” and does not open the door. I figured that I somehow put the required quotes in the wrong place and went back and futzed around with them. Eventually I got back to the entries shown above and it worked. I realize that typos occur, but that is not what is happening here; I very carefully reviewed my entries before hitting return.

I also went to the forums to see an example of a dynamic component, which lead me to download an example component from the forums/learning places. I imported it to a new SU window and it operated as I expected. I opened the Component Attributes Window and saw information as expected. Then I closed the example SU window (did not save it) and went back to my glass and frame example. The Components Attributes window remained open and still displayed the information from the example, not the glass and frame model. I had to close and reopen the CA window before I got the proper information. I tried to wait to see if it would update on its own, but ran out of patience.

It seems to me that both issues are related and that the CA capability (and window) don’t update fast enough to work properly; Futzing around eventually updates CA with the correct information, which seems to be a timing issue. Has anyone else seen this and is there a fix for it besides patience or closing and reopening the CA window?

0 Likes

#2

Try to disable the smartquote setting in Apple native systemsettings (systemsettings-keyboardsetting-use smart quote)

For the panels, use rightclick - Dynamic Components- only, the toolbar icons have some troubles eg. The order of openening is of influence.

0 Likes

#3

Hi Mike,

Now I remember that I had this problem a while ago. I recently reinstalled the OS (actually the Apple folks did) and now I am relearning all of the settings I had changed over the last few years. Making this change fixed the entry issue. I also created the variable first, followed by the On Click, then the RotZ; this makes sense since I can’t really operate on/with a variable/click before the variable/click is defined.

Still not sure about the contents of the CA window, but closing it and reopening it does solve that problem.

Thanks,

Carl

1 Like