OnClick functions not working in 2016 pro

I’ve been using SU pro (Mac version) for about a year & am now finding a use for dynamic components. I need to move a component back & forth in the x-axis, on click, much like a drawer would move. After hours of failure using my component, I started using a simple block & tried everything I could find to accomplish this. Not only did all the Animate functions fail to work, but even the simple Message function is inoperable. Am I overlooking something, or could there be a bug or glitch of some kind here?

It is of course impossible to know where the problem lies without seeing your formulas or the model.

However, attached is an example of the most minimal animation you possibly create.

anim.skp (21.9 KB)

Here’s my simple model, using the same DC attributes as yours. I get an error message saying it’s an invalid entity to animate.animate-test.skp (16.1 KB)

Here’s what you originally had:

I made these changes, and it worked:

The issue was that the X was not connected to the anim, and the quotes in the onClick

animate-testAD.skp (20.4 KB)

Thank you! Finally got it to work in my actual model.