Animate does not accept quotes inside

I am running SU Pro 2017 on a Mac High Sierra 10.13.2. Pro is a recent purchase, although I have had free for several years. I am trying to make dynamic components and run into an odd situation.

I downloaded a door from the warehouse to use as an example and it works as expected. In the OnClick attribute, it has Animate(“RotZ”, 0, -90) and that matches the teachings of the fora I have visited to learn about dynamic components. The problem arises when I try this same thing on my own component in another file. I type in exactly what is in the downloaded file and when I click on the component, I get a message box containing: “ERROR: Invalid entity to animate (“RotZ”)” and the component does not rotate. I convinced myself that I typed in the proper format, so I decided to remove the quotes from inside the Animate function and now it works. I went to the downloaded file and just tried to reenter the Animate function by clicking until it was highlighted and pressing return; I changed nothing in the function. Now I get the same message from SU. So, I removed the quotes from the function in the downloaded file and it works fine.

Is this a Mac thing?

On your MAC, make sure that ‘smart-quotes’ are disabled for this app.
Otherwise typing the standard “…” is auto-replaced on a MAC with smart-quotes which breaks many things !

1 Like

Thanks, TIG. I disabled it totally since, as you say, it breaks many things and now I know why. I have had my Mac for three years after Windows PC’s for many years and (sarcasm ON) enjoy continually learning about all the things that Apple does to improve my computing experience (sarcasm OFF) .


Dynamic Components should really be able to internally replace the so called smart quotes with regular quotes. One line of code would be enough for making the replacement.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.