Component Options not available on imported component

I have created a component with dynamic attributes. If I use that component within the project that it was created, the Component Options window shows the attributes that I have configured.

But, if I save the component as a sketchup file, add that file to my components directory and then add that component in a new project, the Component Options window for that component is empty.

How can I create a component whose attributes can be modified in other projects?

I have included the component file. Using the Component options dialog, the user can/should be able to edit the length and height of the wall
ReinforcedConcreteWall.skp (793.1 KB)

Open the imported component for editing and select the component inside that. I bet your options will show up that way. Instead of using Import to get it into your model, bring it in through the Components window.

If you save the .skp file after you’ve created the component and import that, it will come in with an excess level of nesting. If you save the component out via the Components panel and bring it in that way, you won’t have that extra level of nesting.

2 Likes

I misspoke. I was bringing it in through the component window.

But after deleting the component, removing the dynamic component extension, reinstalling the dynamic component extension and recreating my component, all is well.

Thank you for your help!

That makes me wonder if you installed SketchUp correctly in the first place. You shouldn’t have had to jump through all those hoops to make it work if you had installed correctly.

I did just install 2020.2. But this appeared to be a common problem a few years ago and that was the fix then. It seems it still applies now. The install/update was pretty much a 1 or 2 click thing. Not sure there was much to screw up. But stranger things have happened to me before.

Did you right click on the downloaded installer and choose Run as administrator?

No. After reading a few web pages where people had the same problem (back in 2016) and how they fixed it, I just did the same thing.

It doesn’t take much searching here to see that incorrect installation of SketchUp has caused a lot of users problems. You might take a moment and repair the installation using Run as administrator. Make sure you have the latest version of the installer from sketchup.com/download/all

I think I figured it out. User misunderstanding of how components work.

If you create a component in a project, then save that component, it creates a sketchup file. Inside that sketchup file is basically the component but exploded. And the data that was assigned to the component is in the project data dictionaries.

When I create a component in a project then save the PROJECT and drop it into the components directory, the file contains a non-exploded component. And the data that was assigned is still within the component.

I thought you could just drop files in the component library and it would work. And most of the time it does. But now when you have dynamic data associated with it.

Originally, I was not treating the processes as different. So when I created a component the bad way and it did not work, I “applied fixes” and made the component the good way and it worked. Thus, it seemed like the problem was fixed.

Anyway, thanks again for your help. I will take your advice and repair my installation just to make sure nothing else is wrong.

That’s what I was trying to explain to you yesterday.

That’s actually not correct. Components are SketchUp model files in their own right. If you right click on a component in the model space and choose Save as… or you save the component out to a local collection via the Components panel, you are avoiding the added level of nesting that you got when you saved the model file using File>Save (or File>Save as…)

If you are saving the components correctly it will work as you expect.

If you are creating a collection of components, dynamic or not, save them in a local collection that you can access from the Components panel. Then you can select the component in the collection and bring it into the model by its insertion point to drop exactly where you want it.

Yes. I must be doing something wrong.
Process 1:
Create new sketchup project.
Make a 3d Polygon
Select all of it and make it a component.
Classify it as an IFC WALL
Make attributes for height and length
From component window choose “Save as” and save it.
Open a brand new project
Component appears in component window. It IS an IFC classified component where I CAN edit the height and length.

Process 2:
Create new sketchup project.
Make a 3d Polygon
Select all of it and make it a component.
Classify it as an IFC WALL
Make attributes for height and length
Save the project.
Drop the saved project into sketchup components directory.
Open a brand new project
Component appears in component window.
It is NOT an IFC classified component and I CANNOT edit the height and length.

That’s what you are doing wrong. Don’t save the project that way because it creates the added level of nesting. If you open that top level component for editing and select the component inside, it should have the attributes.

FWIW, here’s an example of a DC I created. I saved it into the local collection using the Components panel. I did not use File>Save to save it after I created the component.

1 Like

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.