Importing Dynamic Components

Hi Community,

I have a question regarding dynamic components. I have dynamic sketchup models that have a “components options” menu. Opening the file directly, I can access the edit the “component options” by simply right-clicking the model. BUT when I import the model into another sketchup drawing i.e. not open it directly, there’s always a parent component on top of the model. So the “component options” menu isn’t available until I “explode” the model, getting rid of the extra parent component, in order for me to use it.

How to I prevent the parent component from being created when I import dynamic components?


Put the dynamic components in a folder and access that folder through the Components window. Use Open or Create a Local Collection in the Details menu.

To make that library easier to access next time, click on Add to Favorites after opening that library.

Of course you can make multiple libraries and sort your components into them. Going forward, then, you can drag and drop more components into the library of your choice by opening the secondary pane (click on the little + in the upper right corner of the Components window), setting one window to your In Model library and the other to the destination library. Then drag the thumbnail from In Model to the other pane.

1 Like

Thanks Dave