Component is invisible in hidden line view

I bet there is an easy fix to this problem. I am using a sink, tub and toilet components for a bathroom design. The sink and toilet show up in my hidden line view in Layout, but the tub is invisible. I assume this is because the tub does not have any edges. I have tried to figure out how to edit the component.
Here is a screenshot of the Layout drawing and a screenshot of the model in plan view.
![Screen Shot 2022-08-03 at 11.50.27 PM|495x499](upload://zzP


Here is the missing Layout view

I would guess that the tub is on a tag that is turned off in the plan view.

Looks to me as if the edges in the tub component are all hidden so without face shading it won’t show. Edit the component and unhide the edges around the top perimeter.

The tub is on the same fixture layer as the sink and toilet. The component itself is untagged. So it is not an issue with tags.
So to I hide the top edge, I open the component and select the top face and then say I hide selected? I will try it…

Isn’t it the other way around? Don’t you want to edit the component and UN-hide the missing edges for the top?

Nested components from other people can be a maze of layer/tags to sort through.

Obscure question: Do you have Auto-Invisible Layer On/Off extension by any chance?

If you created the plans scene first, then import a component that drags in new layer/tags, they will be turned off in the scene because of the extension.

You want to unhide the top edge, open the component for editing, turn on hidden geometry, select the surface and it’s edges, (really just the edges you want to unhide but it’s easier to double click the surface). choose Edit>Unhide (or right click unhide)

1 Like

No such extension. The components are share the same OB-FIXTURE tag. And I always first import components into a new blank drawing so I can edit it and make sure the whole component is untagged.

Thanks this is the confirmation I needed.

Yes that was an autocorrect. Not “I hide” but “unhide “

1 Like

OK, here is the component. I can’t just select the top face. The whole component gets selected. I’m curious how this component was created. Anyway, I still need help making it visible as a vector drawing in my Hidden Line style Layout file.
Freestanding Tub.skp (323.3 KB)

The edges have been softened.
Turn on hidden geometry, select the edges you want to show, right click, and select “unsoften”

A needlessly complicated component. The edges in question have been softened and hidden. You will need to undo both states to make them visible again.

In case it’s too quick in the gif, with the edges selected (and face but that’s only out of convenience) I moved the soften slider to a random point and then back to 0.


1 Like

Thank you for the gif

1 Like

I will use the same process to unhide edges of the drain and tub bottom.

Alternatively, I could select a different component! Haha. But I added dynamic attributes to this one so I could change the size easily. And it matches perfectly what my clients want, so I guess I’ll keep it.