Component as image - how to hide black line outline?

To all,
When I import a component, say a tree that has the leaves formed as an image; i.e. the graphic placed in a flat rectangle for instance. The black line rectangle isn’t visible when viewing the component, but on import into my drawing, all the rectangles (leaves) show the black line outline. Therefore, how does one turn off the black rectangle outline ? :thinking: :thinking:

Hard to tell exactly without an example .skp to look at but I’m thinking you should be able to edit the components and hide the edges.

Yes, that worked, but I gave up as was taking forever… :face_with_spiral_eyes: :face_with_spiral_eyes:
I’ve attached the component as a screen capture to clarify further.

Where are you getting these components? I have to believe you can get similar ones that won’t require all the work to make them useful.

I have had this happen when opening older files. At some version of SketchUp, the visibility of nested geometry started to be controllable via scenes.

3D warehouse, see attachment. I’ll use another component in the meantime until I find a solution.

Go to View > Edge Style and turn off Profiles.

Basics of SketchUp at

or soften the edges with the default tray tool or use the eraser + shift.

In the present case, this would not help you at all, since the border edges are already softened and smooth.

Hi mihai.s,
Thanks for looking at this further. The VIEW in the pull down menu for EDGE STYLE, I think is the same as the main window for default STYLES. This indeed worked, but my entire drawing now looks a little light & odd in places without profile edges !

I experimented with the setting numbers in the STYLES main window with DEPTH CUE, but not quite the same. No: 2 on PROFILES with DEPTH CUE off was my original setting.

It would be good if one could have these settings as well just for components & ones drawing would remain unaffected, sounds like a wish-list !

If you hide borders for every leaf, you can keep Profiles on

You’ll never git rid of profiles completely if you turn them on because that is what they are for.
But it is pretty quick to hide the edges as they are all loose within.

Hi mihai.s,
Yes, as DaveR noted previously.
However, it takes a bit of time though to do every one, so may get back to this as gave up before… :face_with_spiral_eyes: :face_with_spiral_eyes: :face_with_spiral_eyes: :yawning_face:

Use the Plugin Selection Toys - this lets you select geometry based on type.

  1. Open Component Select All
  2. Select All Edges in Current Selection
  3. Hide

Hi Box,
That’s a lot quicker, great trick & now all done my end. Might also try the Plugin ‘Selection Toys’ as noted by bmike.