Black lines around imported models - how to remove?

I’ve imported some plants from the 3D warehouse but they have black lines surrounding them and I can’t work out whether I’m stuck with it like that or if there’s a way of removing the lines.
Grateful for any advice!
Screenshot 2021-03-06 at 22.30.10|690x388

1 Like

Open the components, select the edges and hide them.

Thnks for replying. I’m clicking to select the line, right clicking and choosing hide, but it seems to hide the entire part of the plant not just the black outline

Are you opening the component for editing first? Or just hiding the component?

Upload the .skp file so we can see exactly what you are working with.

Not sure, tbh.
I imported this collection from 3D warehouse, straight into my design:

but wanted to position each of the plants in different places, so Exploded the set which separated each of the individual plants but I don’t know whether that was the right thing to do. It meant I could move them independently but maybe not correct for being able to edit them now?

I meant upload your model file.

Ah ok.
Having trouble doing that - it’s 23mb which apparently is too big to attach on this thread. Need to finish for the night now anyhow - will see if things look any clearer in the morning (and will upload to this thread if I can work out how…)
Thanks again

Upload to a file sharing service instead, like Dropbox, OneDrive or WeTransfer and share a link, when you resume working on the model.

PS. When I downloaded the file from 3D Warehouse, I see that it has been saved with Edges and Profiles turned off in the Styles window.

If you can manage your whole model to show in that style (improbable) you will continue not to see the edges.

If however you turn edges on first in the style you are using to which you have imported and exploded the overall model, you should then be able to do what Dave suggested, select the edges only for each face in each separate plant, and hide them. One of the easier ways to do that is to open one of the plant faces for editing, triple click to select face and edges, then Shift+click on the face only to deselect it, then while the mouse is over an edge, R-click and choose Hide the selected edges. Repeat for each face in each plant.

Face and edges selected in one face


Deselect face

Hide selected edges

All edges hidden in the left plant, none in right hand one

If you were using a desktop version of Sketchup such as Make 2017 you could use ThomThom’s Selection Toys plugin to pick only edges within a multiple selection of the whole contents of one plant.

Thank you both.
Here’s the model (my first project using sketchup, so doubtless painful viewing for anyone with experience…):

I had a go at clicking through the different options to find just the edges as per your walkthrough, John. I could only manage to select individual sections of black line and hide them one at a time - and there are dozens per plant. Couldn’t find a way to hide all of the surround line without also hiding the content. There’s a rough and ready before and after to compare sitting on the lawn. Probably good enough for the purposes of what I’m doing, but pretty time consuming to have to do this for all of the different elements of one component and then each plant in turn, so ideally would want to be able to do them in bulk.

I’m not sure how to do this: If however you turn edges on first in the style you are using to which you have imported and exploded the overall model,
Is that available in the free sketchup web version?

Thanks again for your help

I see the same. I reported this behaviour when version 2020 was released. Geometry that was hidden in the original file became visible when the component was imported into a new file. It ws nuisance but basically you had to open all the subcomponents and hide the edges you don’t want to see. The why of it was because scenes in SketchUp today have the power to regulate the visibility of objects inside components and groups. It was fixed in subsequent SketchUp releases. I suspected a regression bug.

However, in the “Vegetation set” file, the edges are not hidden, edge display is merely turned off in the style settings. This will not follow the components to a different file.

In principle I prefer not to tag any geometry with other than Untagged, but here, until the behaviour is somehow made even more reliable, I see a use case. The tag name ought to be somehow standardized, I suggest “Invisible edges”.

Sadly, it doesn’t apply to geometry within components. I think I have seen a plugin that can hide edges within a component in one click, but I cannot remember what it was or where to find it.

Curic Deep Select, but the OP uses SketchUp Free (web) - no plugins

Thanks a lot @mihai.s !
Here is the vegetation collection with edges hidden, took just seconds with the plugin.
Vegetation+set.skp (2.3 MB)

1 Like

Amazing - thank you so much everyone. Hours of grind and swearing avoided

Your profile says you are using SketchUp Free so this must be a hobby thing. Don’t let it get to the stage of grind and swearing.

Good point!