Colour by Layer Help


I hope I am missing something really simple here.

I’ve created a Model where I need some objects to Display a different colour, in one of the Scenes so that I can create an overlay.

Anyway, the Components are all created on Layer 0 and then assigned to a Layer. By using Colour by Layer in the Style Setting, I was hoping that these Components would display as the required colour.

I could not get it to work, so I created a very basic Model, (attached), to illustrate my issue.

1 - I created a rectangle on Layer 0
2 - Deleted the Face
3 - Created Component
4 - Assigned a Layer to that Component
5 - Created a Scene
6 - Changed the Style to use Colour by Layer

The problem is that the lines should show Blue, as this is the colour of the Layer, but they show Black.

Any help would be appreciated.

Kind regards


Sketchup Colour by Layer.skp (2.5 MB)

Do you want to look at it together?

Yes please @DaveR


I’ll send a PM.

Thank you.

Mike, you need to set the color of the edges in the style to By material.

1 Like

That’s what I did @Guy, but no joy.


1 Like

Your color by tag was off.



Thank you @Guy, @mihai.s and thank you @DaveR for the online tutorial. Always good to chat.

Problem solved with the ‘Colour by Tag/Layer’ in the Styles Setting.

I put my mistake down to me being an idiot, getting old, and being tired :wink:



No problem. Mike also be aware when you have Color by Tag on and you use the SketchUp Paintbucket the Color by Tag mode is automatically turned off.