Colour by Axis has stopped auto updating when switching between scenes

Hi all,

I’ve just updated from 2017pro to 2020pro, and have noticed a small but annoying occurrence happening in an existing model to do with the colour by axis display. (I do not believe this is a fault with 2020 as I have only found the problem with certain files).

I typically have a few scenes set up in my template that only control / remember the axis, so I can set multiple and save them to each scene and quickly flick between several wings of a house as I work to the inferencing locks (red/green/blue)…

I frequently toggle between the visual display of lines ‘all same’ and ‘display by axis’ to highlight which axis I have currently got on the saved scenes; and this is where something is no longer quite right…

Before the display of which geometry was on the axis would automatically update when scene switching… but now I have to toggle the display setting line back to ‘all same’ and back to ‘by axis’ to force the update of the on screen display. The axis’s are changing, but the display of the colours is no longer auto updating.

I have replicated this scenario in a template that I have created and it does the same thing, however I have opened a default template from the fresh install, and it does as expected, leading me to think that I have inadvertently changed a setting somewhere.

I searched the forums for this and found an old thread from several years ago where someone that sounded like they had the same issue between 2016 and 2017 ! - but the thread ended without published resolve.

Please can someone shed some light on to what setting this is ? Or confirm that this is something to do with the upgrade from 17 to 20… which I do not believe it is.

It’s a minor thing, but as I use this toggle a lot in my workflow, it’s really annoying me, and also annoying me as I cant figure out why its doing it!

Many thanks in advance.

Alan

You might have (accidentally?) disabled the warning that you’re creating or updating a scene without saving the changes you’ve made to your style. You can reset all the warnings here:
Preferences -> General -> Reset all warning messages.

If you can share an example file here of it not working, someone might be able to help.

Hi,
Thank you for your suggestion. I do in fact disable the style warning change, but I don’t believe that to be the problem as I have also done that in 2017 and it doesn’t affect this scenario.

I am putting together a video to demonstrate, which I will hopefully try and post on here.

I can see in your video around 1:22 that there’s something wrong but I can’t replicate it here on SketchUp Pro 2020 on macOS High Sierra.

Can you share the .skp file?

colour by axis scene not working.skp (179.8 KB)

So the file attached is the one that when in 2020 it doesn’t work, but then I saved a copy as a 2017 and opened it in my 2017, and it works !!

So could this be an issue with my 2020 install ?

I see the issue with your file too in SketchUp 2020. color by axis isn’t working properly.

Spooky ! Cheers for your reply.

What style do you have active in that last video?

I cant be sure as I closed it, but I’ve just opened and tried again, and it appears to be ‘HiddenLine4’ in the default Styles…

Several of the default styles only do what you’d expect if profile edges is on in addition to or instead of edges.

In fact, turning profile edges on, makes all the styles work as expected… and none of them do what is expected if only edges are on…

I think I’ve narrowed it down to working when profile line thickness is bigger than edge thickness. If edges are off (zero thickness?) and profiles on it works even if profile line thickness is only 1. With edges on you need profile line thickness to be at least 2 for it to work. I’m not saying you’ve set your style wrong, this looks like a bug in SketchUp.

Switching color-by-axis on and off forces it to refresh as does opening a component for editing then closing it.

You’ll see the problem even with some of the styles that come with SketchUp 2020 such as the wireframe one that has profiles off. Any style with profiles off or profile line set to less than 2 will show the problem.
Edit: assuming you change the style to color-by-axis as I can’t see a default one that has this setting.

Yeah, I was just making another video to those exact conclusions !

I wonder if this edit isn’t a bug, but was a necessary evil to get another new feature to behave as expected ? If not, then how do we raise awareness to get the bug either fixed or explained ?

On larger models, toggling on or in fact working with it left on (color by axis), does cause performance issues, and so I only tend to toggle it on and off to check which axis I am currently working on or want to switch over to…

Could it be that they removed this live/automatic updating between scenes to help improve performance ? This would make sense if it were also the case for the more intensive edge styles like profile / jitter. etc…

I’ve moved this to Technical Problems->Sketchup
You could ask a member of staff, maybe @colin could help?

1 Like

We updated SketchUp today, but the problem is still there. I’m checking who would be best to log the issue or would know if it’s a known problem.

1 Like

Update on this:

QA have looked at the issue and will create a bug report about it. It seems the problem was introduced with 2018, not just in 2020. The symptom only shows with groups or components, raw geometry updates ok. Also, hiding and showing edges is enough for it to refresh correctly.

When the problem is fixed it would go into the next update, but as we only just released 2020.1 today, you can imagine it may be some time before that update appears.

3 Likes