Coloring irregular shapes

Hexagon cannot isolate irregular shape
Hello, See the attached file. I’m trying to color in the irregular narrow strip within the larger hexagon. How do I isolate that narrow strip? When I try to select it, the large shape above is also selected.


Share the file so we can see exactly how you have the model set up. From the Profile edges and the selection it looks like those edges aren’t dividing the face into separate regions.

Attached is the SKP file.Hexagon cannot isolate irregular shape.png

Tube RH 3.skp (212 KB)

Left end of the lower edges is off the surface.
Screenshot - 9_8_2023 , 1_58_43 PM

Right end of the upper edge is also off the surface.

Turn off Length Snapping in Model Info>Units.

That helped the problem partially. However, as seen in the attached image, there was still bleeding into the upper part of the hexagon. I’ve attached my latest SKP file.


Tube RH 3.skp (208 KB)

You still haven’t fixed the upper edge.

Zoom in close so you can see the bad geometry.

You also still have bad geometry near the lower one.

When you get it cleaned up and the new edge properly drawn it won’t show as a thick profile edge.

Length Snapping Disabled.pngAs you can see from the attached file, I have disabled length snapping. However, there is a related problem.

When I use the Orbit tool, the colours move. You can see that in the attached animated GIF. In the event that the animated GIF does not work in this email, I have included a copy in this web page: .





Here is the skp file I should have included in the previous email.


Tube LH 4.skp (218 KB)

It’s probably still a ‘bad’ geometry problem. It looks like ‘Z fighting’. This happens when you have more than one face overlapping the same space.

As DaveR pointed out, the problem may have started when you had length snapping enabled. If you carefully scrutinize your edges and faces you might be able to find and correct problems. One the other hand, you might want to try re-drawing from scratch. Sometimes it’s easier to start over than to fix little errors that crept in.

1 Like

That looks like “Z fighting” – when there are duplicate surfaces competing to be displayed.

1 Like

You need to understand context,
You are getting z-fighting which is two faces fighting for graphic dominance. This is because you have created faces that are outside the ‘Group’ but basically in the same place.
Here you see I triple click to select all the loose geometry, I then cut it to the clipboard, you won’t have this in your context menu, go edit/cut. Then I double click to open the group for editing and Paste in Place. (again edit/paste in place)
GIF 9-09-2023 5-36-31 PM
Getting your head around the concept of ‘Context’ is quite important.