Keeping lines on the same plane

Upper right hand corner closeup
Hello, At each point in the hexagon image you will see a shape looking like a V. I’m trying to connect those Vs in such a way that the inner hexagon will be surrounded by a hexagonal perimeter composed of narrow white shapes like you see above the inner hexagon.

The 4 lines to the right of the white shape appear to be connected. Yet, the shape does not become white.

Also attached is a closeup of the upper right hand corner. At a highly magnified image I could see that the line did not connect to the point on the V. So, I added a tiny straight line to complete the enclosure of the shape.

SketchUp does not seem to like that. Does anyone know why the slightly altered shape does not turn white? Does moving the line take the shape off the plane? How can I avoid this problem?

Thank you.

Peter Enns

PS Thank you for whoever suggested that I find an online tutor. I found a good one but my time with him is up.
Hexagon A June 28.skp (123.8 KB)

Hi Peter,

You have Length Snapping enabled and Profiles turned on. Length Snapping may be contributing to some of the problems here where lines are slightly off. Profiles make the lines thicker and harder to see small gaps.

You can trace over some shapes to create faces:

Some of the lines (i.e., edges) don’t connect or are crooked:

Screenshot 2024-06-28 125608

I’d start over with a saved template that has Length Snapping disabled and Profiles turned off.