Clipping and missing faces

I have a model that I did not work on it for a long time and now that I have entered there is a problem of “Clipping & missing faces”
I have tried all the tips on the help page of sketchup on this subject, I brought the model to the beginning of the axes, and the problem still exists.
This is a two-story house of normal dimensions. I have no option to put a camera inside the room because the walls are interrupted and of course it is not possible to walk inside the model as I could in the past
What can I do
with gratitude

There is probably something lying far away from your actual model. Orphaned text labels can do that too, and a stray line is enough. Are you still using version 2020? You could try:

  • turn on “hidden geometry”, “hidden objects” and all tags.
  • select all
  • deselect your actual model with a left to right selection
  • press delete.

Or post the model so others can take a look.

You are probably right but the model is huge and it is not possible to mark everything and then isolate the model.
What I did , I marked the model without the accompanying drawings and without the Location Terrain ( that included trees and buildings ) and saved it as a component which I opened separately as a new SketchUp file and it worked out .
Highly appreciate your help
All the best

People are often caught by the terrain, if it is big it can cause clipping even if on a hidden layer/tag.

It seems that this was indeed the source of the problem . It was very very big !
Thank you !