Clearing component's enormous bounding box


#1

I have created a component that becomes a tiny, unscalable item in an enormous bounding box. I can’t see anything else within the box, but I’m assuming there’s some little forgotten bit of geometry somewhere. Is there a way to clear the bounding box of all extraneous leftover material? And why is this component not scalable? I didn’t do anything different when making previous components. Thank you!!


#2

open the component for editing…
use “Select All”…
drag [ with shift ] to ‘de-select’ the main items then ‘delete’ any other bit…

the bounding box should shrink to fit and you may then be able to scale…

post the skp file for others to check…
john


#3

As you have concluded, this symptom almost always means there is some stray geometry far away from the meaningful content of your component.

John beat me to the post with a way to fix it. One thing though: turn on View->Hidden Geometry first or you won’t be able to select the offenders if they are hidden.

Another thing to check is where the component’s axis origin is located.


#4

It is possible too that only the axis of that component is far away, this would lead to a big bounding box too.


#5

Also could be related to using Advanced Camera Tools.


#6

And don’t forget to turn all layers on. Geometry on invisible layers wont be selected either.


#7

Hidden wireframe is not selectable;
Show hidden geo;
Set rendering to wireframe; Right/
left select the area you think the item is in;
Select hide; Select all and delete;
Select unhide. If you can context click on the entity select reset scale or if you want you can scale definition.