Cleanup3 is taking like 3 minutes now vs 2 seconds

I use Cleanup3 all the time but for some reason it now takes a long time to process. Something that would normally take 2-3 seconds is taking 3 minutes. I am on a M1 Max Mac Studio. Sketchup runs good it is just this essential tool which lags. Is there something I can do to try to fix it?


The file has more stuff OR you maybe have the “delete duplicate faces” box ticked, which always takes a long time vs not using it (sometimes HOURS)

Those would be my guesses.

Generally, the bigger your model, the longer it takes. How many faces/edges in your model?

I would have to agree that your model is likely more complex so there’s more or CleanUp3 to do.

Keep your models less complex. Give CleanUp3 less to do. Maybe change which steps you are having it do. Run it more often.

The thing is I can run cleanup3 on my pc on the same model and it is still a 2-3 second deal (maybe 10 seconds sometimes but never much more than that). The complexity of the model has to be a bit high due to it being a house. I also keep my models super clean. It just seems like it is just not working right with Cleanup on the M1. I tried turning off the merge coplanar but it did mot help.
Just did a test on the same model. I draw a line on the wall of the house. Grab everything and run cleanup3. On the M1 it takes 58 seconds and 1 second on the PC. Attached are the settings for each. Maybe uninstall the extensions and re-install?

Your profile says you are running SU 2020 and MacOS Ventura.

2020 isn’t made for M1 , so takes a performance hit and Ventura causes endless problems with older software.

Can you share an example file? I can try it on my M1 setup where everything is correct.


Yea I need to update that

Good old uninstall and reinstall fixed it. I deleted the extensions and re-installed. If it aint working unplug it and plug it back in. Works 90% of the time :slight_smile: