Cleanup weird bug

Thomthom’s Cleanup is working beautifully at my work-pc. When trying it at home I get this (as shown in the image). I have installed it properly, on multiple version trying to find the problem, because it’s only on my personal pc. So the problem is with my pc not the extension. But i am curious to find out why.
Help people.
No errors shows on ruby console, and the extension works if you choose from the drop down list. So it is a display bug.

Maybe @thomthom has an idea?


Is that Windows 10?

What is the installed version of Internet Explorer?
CleanUp uses UI::WebDialog which uses the embedded system browser (IE). I’ve seen some users end up with corrupted IE installation that can cause issues like this.

It is windows 10. Thank you for replying Thomthom sir.
Is the system file checker tool sufficient enough to check if IE is installed properly ?
I used it, it repaired whatever problem there was, but the problem persists.
i tried reinstalling the plugin in case it makes its own copy of the files it uses, but nothing changed.
i think the problem is not in sketchup as you suggested though, because i have a similar problem with profile builder not being able to see assembly files in the assembly dialog.

Yea, this is some system corruption of the Internet Explorer engine.

Have you tried starting Internet Explorer? Test if it’s able to load a website? Might be worth checking the settings of IE. I think in one case a user found that JavaScript had been disabled.

Thought it was just Me !
I have this problem as well…though it seemed to work once on first go and still does (apparently) when I chose use ‘Clean with Last Settings’

Also problem with Materials Tools - List Textures in Console - where I just get a blank dialogue box, see attached - wonder if problem is connected

It might also be related to JavaScript as I think a while ago I had some error message on that…?
All beyond my grey matter scale so any (easily understood) help appreciated

I think I should mention that the other day for the first time ever, some program or the other wanted to open a small IE browser window. It opened but it had a OEM hijack informational page with a Microsoft message in it to encourage update to Edge with a link.

I had just the day before done the latest Win10 update.

Microsoft is choosing old services to discontinue. Just this past week they shut down the MS Gaming services for Win8/8.1. My mother is so disappointed she can’t do the daily challenges anymore for these games. (Her machine has an old integrated Intel 4400 graphics for which there is no Win10 driver and it’s not worth paying the hundred smackers to upgrade to Win10 on that machine anyway.)

This is unrelated. You need to open the Ruby Console before using that function.

As use of Ruby Console is above my ‘brain grade’ had to look up how to do that at SU web site - seems a few changes have occured since that was written but got there.
Tried Materials as you advised - and yes success !
Many Thanks for explaining that
So that just leaves the Clean Up Problem

If you try Internet Explorer, do it load sites properly? Or are you seeing issues there as well?

From a search of this issue I saw you mentioned IE and Java a while ago and IE does seem to load sites. For Java, have checked that under Scripting that it is Enabled for Active Scripting though ‘Updates via script’ and ‘allow website…etc’ these two are both disabled - is that OK or wrong??
I have noticed that a SU webinar link sent to me by email would not open on my Windows 10 PC would not open but just found out it did on my Android phone and tablet…is there a connection there?..maybe the problem is in my PC…or not

@thomthom Yes sir. Internet explorer is working and it loads pages. Even switched to edge so the microsoft edge pop-up is gone from internet explorer as the other reply mentioned. But the problem persists.

Update - SU Webinar link problem solved by turning off adblocker as suggested by Teeem so no connection to Cleanup issue…onwards and upwards…

Can you post a screenshot?

(Btw, Java is not the same as JavaScript)

The choice of browser you use is not relevant here. SketchUp, and other applications will use the Interner Explorer engine (note I’m not saying browser here)

Can you check the same settings as tede20?

1 Like

Yes sir, I already checked these options.
Here’s a screenshot.

I only mentioned browser because the microsoft edge pop-up hijacking informational page was mentioned above.

Hi ThomThom
I followed as far as I could -

but not 100% I have the correct info
Not sure what Microsoft VM and did not spot Java Settings see markup

then the screen shot (hopefully is thw one you are after)

Just an observation. My laptop has a completely different version of windows, which is 8.1. And both my devices have the same issue. It must be something I am doing that I just cannot put my finger on. Thank you for helping anyways.

FYI re IE11: The following was announced last May … I am wondering how this policy will affect the ie engine DLLs that applications use ?

Hi ThomThom

Any further thoughts on problem a couple of us are having with Clean up and teh mysterious black/Dark Grey dialogue box