Clean Lines on export


#1

I’m exporting a SU drawing to create a clean flat line drawing, no shading. The drawing is complex and includes a lot of ovals which are circles in perspective. I want to print the drawing at A0 scale after some colour work in Photoshop.
I exported the drawing as a dxf file and opened it in Corel Designer which works perfectly, theres some cleaning up of artefacts but not too bad. Problem is that when I try to change the line weight to 1pt or larger the facets render as disconnected lines. Each has a hard coner and where they meet at angles theres a ‘V’ gap at the connecting point. its very messy and doesnt work. Heavier lines make it worse, I can adjust line ends but it doesnt solve the problem, to make the drawing smoother I’ve increased the facets in the ovals which has made it even worse, given that its A) I need the lines smooth as I can get.
I’ve tried a few approaches but cant seem to beat it. So before I use the drawing as a template and redraw the whole thing in Designer or Illustrator to get a good vector drawing ( a big job) I thought I’d see if anyone has a suggestion.
The exported line drawing looks good, its increasing the weight of the lines thats causing problems. Will keep at it but any suggestions appreciated.


#2

Have you tried exporting as a 3D DXF instead of 2D? Give that a shot and see if it works for you.


#3

Doesnt work as the view changes dramatically. At least as a 3D export to Corel Designer.


#4

What do you mean “the view changes dramatically”? Could you show an example?


#5

Prefer ot to as its a work in progress but it creates a view from below, tried it 3 -4 times in DFX and DWG getting same results, orientation is correct. + the result is in wireframe. Unfortunatly Designer doesnt recognise Collada.
What I need is a 2D drawing clean simple. I’ve tried it a few more times using various approaches, the hairline option is fine but as soon as I for eg apply a .5 line thickness the jaggys are rendered as seperate lines and it becomes messy, heres two details, hairline at A0 is nearly invisible, 1 point would be workable, I’ve applied 2pt to show the problem, curves are the worst.


#6

Are you setting the view you want n SketchUp before making the export?


#7

Of Course. I know my way around these aps. I think its best to create a copy in Illustrator and do it properly.


#8

Unfortunately this is the nature of SketchUp. Face geometry consists of flat faces that are delimited by straight edges, and they remain straight when you export the view as a 2D drawing.
I don’t use CorelDraw so I might be suggesting something that it cannot do, but in Illustrator I would have these options:

  • I could select the connecting lines and weld them into a curve
  • I could apply another kind of line ending, round, for instance, to mask the connections and make them slightly overlap.

BTW, instead of DXF as the exchange format you could also use PDF or EPS.

Anssi


#9

Thanks, its actually Corel Designer, a cross between a 2D CAD program and a Design program similar to Illistrator, actually a very good app to work with as it has a foot in both camps. I refer to illustrator as most are familiar with it. In this instance I think that to do the drawing properly and seamlesly I’ll have to use the line drawing as a template and do it again in Designer / Illustrator. Patience…