How to remove random lines being added in dxf exports

dxf
cad
export

#1

Hello everyone, I seem to be having an annoying issue whereby every time I go and export my SketchUp drawing as a dxf and then import into another program, it has the lines fragmented into many lines, i.e, an arc is 4000+ small lines instead of one smooth line.

Also, I see that in some corners where I have joined lines, there is additional lines being added. Thus, have to manually remove these lines every time.

Thus, is there something in SketchUp I can configure to stop it doing this ?


#2

Are you exporting as 2D Graphic or 3D Model dxf?

The 2D export is effectively (and deliberately) an image of the current view, as displayed. It includes all effects such as SketchUp’s representation of circles and arcs as series of edge segments. This happens because the model is actually 3D, whether you drew on a single plane or otherwise, and SketchUp has to somehow render that 3D onto 2D for the export.

In contrast, the 3D Model exporter checks for SketchUp’s circle metadata (where it hasn’t been lost due to editing or manipulation of the circle) and exports a true circle or arc to dxf.

As to the other extra lines, without seeing a specific instance I can’t guess what is going on.


#3

I am exporting as a 2D graphic.

Currently, have no file I am able to send but the extra lines occurs around the joining of two lines


#4

Hello everyone, I seem to be having an annoying issue whereby every time I go and export my SketchUp drawing as a dxf and then import into another program, it has the lines fragmented into many lines, i.e, an arc is 4000+ small lines instead of one smooth line.

Also, I see that in some corners where I have joined lines, there is additional lines being added. Thus, have to manually remove these lines every time.

Thus, is there something in SketchUp I can configure to stop it doing this ?

Update:

Screenshot below is an example of what happens:


#5

The fragmentation issue is difficult to respond to since you can’t supply a SKP for us to inspect

As for the extended lines, I’d start by editing the style and turning off Extensions. Turn off Endpoints if they are on, too. Then update the style.

If you are going to be making exports to DXF regularly, edit the style and update it. Then use the updated style in a new default template.


#6

DaveR fragmentation is okay to be honest.

Regarding the extending lines, noob question how can I edit the style and turn off extensions and endpoints ?


#7

Open the Styles window. Set it to In Model by clicking on the little house icon. Click the Edit tab, the make sure you’re in the pane for editing edges and untick the box for Extensions. Untick Endpoints while you’re at it and then click on the style thumbnail with the circular arrows on it.


#8

DaveR regarding the overlapping intersection lines, your suggestion has done the trick I believe.