Missing Segments and Geometry DFX Export

I am trying to get some metal cut for a design I am working on. They require a DFX file so I upgrade to pro to export in that format. Once I sent them the files they said Should round my corners more so I did that but after adding segments to my circles and curves, they are missing things in the dfx files i send them. I tried the solid inspector it just deletes all my circles? Can anyone help me with this? I also attached the SKP to look at. They only let me upload one picture but they the metal cutter is missing edges on the files. Like they are not solid All together.skp (13.2 MB)

Set up the standard top view with the camera set to Parallel Project and then use the 3D DXF export, not the 2D export.

Solid Inspector isn’t useful in this case since your model consists of 2D shapes, there’s no way they would ever be considered solids.

Thanks. I tried again and they sent me this

Maybe it’s their software? This is what I get when I export the DXF and open it in DoubleCAD.

And after exporting I see this in DWG TrueView:


All together2B.dxf (296.0 KB)
I exported only the edges, not faces.
BTW, it would be courteous to purge your models before posting them on the forum. the size of your model went from over 13 megabytes to 200 kilobytes when I purged it.

1 Like

What @Anssi said.

Screenshot - 12_3_2020 , 12_40_56 PM

awesome thanks. I am going to send them your dxf and see what they say. Sorry I dont know anything about Purged. I will have to look into it. Thanks

This is just a standard export. There have been discussions here lately about arc directions etc. that seem to prevent some CNC software from interpreting these correctly, so we’ll see. I don’t do that kind of work so this is the best I can do.

my problem must be in exporting. your file is perfect. I went to try to do that my self and had the same issue. How do I export only the lines?

yeah your file is great they just want it split up lol

I exported directly from the .skp file, not from LayOut.
Screenshot - 12_3_2020 , 12_57_49 PM

If they want them split into separate files, make separate SketchUp models.

You are exporting a 2D DXF. My export is from the 3D Model option. A 2D export always results in segmented arcs and circles.

1 Like

Alright I think im getting closer with that but like you guys said before those files are huge. Where do I do the Purge?

Window>Model Info>Statistics.

In SketchUp Shop, purge buttons are found on the component etc. windows that open from the buttons on the right. I found no Statistics page (may be that I just don’t know Shop well enough).

No. There’s no Statistics panel in SketchUp Shop. I was talking about the desktop version.

This thread was apparently posted in the wrong category. I’ll move it.

i found it thanks

I just cant seem to get it. here is the link to my google drive with the 6 files if you could help me out? I need the dimensions as well. https://drive.google.com/drive/folders/1DuDmZP2rBaMsg3tStKp03wxJdRmEuO6E?usp=sharing

I figured it out, for some reason the browser version didnt like doing this. I download the desktop client it it worked fine.