Overlapping lines on Exported DXF's


#1

I have been using Sketchup Pro 2014 for a while to do simple 2D sketches to export to a laser cutter or CNC router. The following problem occurs frequently on simple rectangle drawings.

Here is what the exported DXF looks like in various other programs(LaserCut, VCarve, Aspire)

As you can see, there are extra lines where my vectors meet. Normally it is no problem to just and manually delete the extra lines, but on more complex drawings, it is becoming a pain. Multiple searches on the forums and on google have yet to return a result with similar situation. This problem has existed on several different machines with several different versions of windows which leads me to believe it is user error on my part. Any advice would be greatly appreciated.

Jeremy


#2

Do you have “Extension” or "Endpoints"enabled in your style, and "Show Extensions? in the Export options?

Anssi


#3

Thank you very Much Sir!!

Both on View >Edge Style > Extensions was enabled and on Export 2D >Options > Show extensions was also enabled.

I de-selected both and VOILA! Perfect export with no extra lines.

Problem solved.

Thanks Again,

Jeremy