Change to animation feature?

I just updated my computer and sketch software. I opened a model to make a little animation. I made some scenes but when I press play, nothing. has something changed in how this is done?

Nothing has changed with scene transitions. Open Window>Model Info> Animation and examine the settings there, ensure that that “enable scene transitions” is checked.

yes it is on. the I press the scene tab at the top of the window the scene moves a fraction but not back to where I set it. In the thumbnail the location is accurate however.

Curious, in the scenes pallet with the details expanded are all the properties to save checked, is camera position perhaps not saved? But you said it moves a little?

Better post your model (skp file) here so we can take a look at what’s going on.

1 Like

rodriguez 1.skp (1.5 MB)

when I click muulptiple times it incrementally moves towards the position I want it to move to

With the scenes pallet open and expanded I see that your “scene 3” does not have the camera location checked, therefor there is no change in camera location associated with that scene. Whenever you go to scene 3, other properties change but the camera remains where is is. Check that box, then choose a new camera position and update scene 3.

5

rodriguez 2.skp (1.5 MB)

I deleted the previous scenes and made four scenes, one from each side of the house, with the camera position checked. still won’t play animation and when a scene tab is pressed the view does not correspond to the scene I created and that can be seen in the thumbnail

This version of your file works fine for me. When you press play do you wait for 1 second to see the first move? You have it set to pause for 1 second between each scene. Have you updated the thumbnails? Perhaps they do not reflect the true camera positions? this is what I see:

6

Kind of a different issue, is there a way to set up multiple animations in a single file?

There is not a native way to have multiple pre-established animation sequences. The fastest way I can think of to achieve this with native tools is by using the scenes panel to include or exclude batches of scenes, so that only the desired scenes are included with each export. Say the first 10 scenes are one sequence and 11-20 are a different sequence. Open the scene palette and expand it, then batch select (or non-sequential select multiple) every scene not to include and uncheck include in animation. All the not included scenes are listed in parentheses to indicate their exclusion from animation. Set up like this, either playing directly in a presentation or exporting an animation will only use the included scenes. To export the next animation sequence, batch select 1-10 and un-include them and re-include 11-20, then export again. It sounds more complicated than it is in practice.

2

I believe there are several scene management extensions that may help with this but I do not use them so can’t comment.

Yes, that is probably the only way to accomplish it. I was thinking about the situation where you are using LayOut as a presentation tool and wanted to include different animations on different slides/pages. I think this could not be done without not creating movies and including the movies instespad of playing the animations in the windows in your LayOut document,

1 Like

that is so odd. when I press a scene tab it does not go to the view that I set it for, it goes a tiny increment in that direction and if I continuously press the button it may eventually get to that view. here is the same file I posted and what I see
rodriguez 2 what i see.skp (1.5 MB)
also, when I go to export_ animation_save as_export nothing is saved.

Odd indeed. This file runs flawlessly for me. Are you running on M1 as your profile indicates? Native or through Rosetta2? Has this worked in the past for you or did it recently stop working? Is this a fresh install of SketchUp?

I threw out and reinstalled sketchup and now it works. sigh! thanks so much for all your help.

Sometimes one must sacrifice a fatted calf and recite incantations. Glad it’s all working now. :+1:

1 Like