I'm having trouble trying to animate

I must be missing something with scenes. I have a 3D drawing. One of the parts in the drawing is movable. I want to create an animation showing the two positions of the movable part. I create a scene with the part in one position and I create another scene with the part in the other position. The Scenes window clearly shows the different part position in each scene. However when I click on either scene button all I get is a small zooming effect (in or out) but the view only shows the part in one position. I expected the animation to transition from one scene to the other but it does not.
What am I missing?
John

Scenes save a lot of settings, but location of geometry is not one of them. If you want to animate movement of geometry, you will have to get ahold of an extension like Animator.

Or , make copies of the item and put the different positions in different layers. (= quickest way)
You can also make a dynamic component of the item, and animate with the interact tool ( Pro only)

1 Like

Okay, then why do the two scenes I saved show the part in different positions?
John

I am guessing that you did not update the scene after you move it, so that is the old thumb nail. Sketchup does not natively have any movement animation tools. Animations between scenes control things like camera movement, shadows, scene changes… That sort of thing.

Mike,
Yeah I’ve used that process before but then I discovered the scenes/animation features and thought I could use them
John

But it sounds like even if I did update the scene, it still wouldn’t show the movement. Isn’t the change in part location a change of the scene? I guess I’m a little lost on the value of animation (or lack thereof).

This simple example has two copies of the box laid on top of each other, one is on “closed” layer and one is on “open” layer, with the lid rotated upwards. I made two scenes, one with open active and one with closed active.

Here is the file if it helps, you can inspect the scenes/layers openclosed.skp (28.6 KB)

1 Like

Animations are used to visually transition from one scene to the next. Location of geometry is not a value of a scene. Items (lines, faces, groups, etc…) can only exist in one place in a model. Moving between scenes does not change where they are located.

2 Likes

Still a little confusing but thanks for your reply. I’ll have to adjust my thinking and use one of the workarounds as suggested by the other two responders.

Thanks for the response. I guess I’ll go with the multiple layer approach and play around with the animation as you demonstrated quite nicely.

Okay, new issue. How do I stop the animation once it gets started? I don’t have a “pause” and “stop” button like you show in your video.

I’ve not experienced that, you should have the window. Have you tried the ESC key? Someone might know better.

Btw- I only used the animate function to show you the idea, it gets annoying after a while. I would normally just click the scene tabs to see the different scenes.

EDIT- Spacebar stops the animation (windows)

I just have the Make version. Are you using the Pro version?

The ESC key does nothing. I looked through all the menu items and I can’t find anything that eludes to a display of the animation control other than through View > Animation and that only allows adding, deleting, playing or settings, no pause or stop.

on a mac, you can add the ‘Play/Stop’ buttons to the ‘Custom toolbar’ using R-Click and drag…

john

??? Yeah I’m on a Mac but where are the Play and Stop buttons? Gotta know where to find them before I can right click and drag.

2 Likes

Okay, got it. “Slideshow” versus “Animation”, I guess its one of the differences between Mac and PC.

Enough of this diversion, I’m going back to work on my drawing.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.