Change portrait/landscape in Match Photo

matchphoto
photomatch
photomatching

#1

Hi hello

How do I rotate the loaded photo in Photo Match?

All the adorable tutorials on the internet miss the very first and the most important issue that I run in when trying to start with Photo Match… My house photo is taken in portrait and it gets loaded in sideways as landscape… the “rotate” selection on context menu only rotates axes and I’m unable to google for an answer for apparently such a trivial question :confused:


#2

Was you photo taken with a phone or iPad?

Use an image editor to rotate it so it comes in with the right orientation. Do not crop the image, though.


#3

Yes, ty! Phone and it’s silly that win10-rotate rotates it only for win10 views and not the actual image :confused:


#4

There are a lot of applications that automatically rotate images to match how they were taken with the phone/camera. The files aren’t really rotated so for other applications, you have to do it manually like in the old days.


#5

I am having the same problem. All my photos are importing upside down. All of them.
Why can’t I just rotate the photo?

Please help.

Drew


#6

Can you share an image that does this?


#7

I have even tried saving the photo upside down, then Photo Matching it - and it stills comes upside down!
ugh!


#9


#10

It comes in right side up for me in SketchUp 2018 Pro.

I’d be looking at graphics drivers. What is the graphics card? Try updating the drivers. Your profile doesn’t have the right information.

What version of SketchUp are you using? Your profile indicates you are using SketchUp Free and also 2018 which is two different versions.

As photos for Match Photo go, this one works pretty nicely. It was easy to set up with all those straight lines.


Is the image right side up when you open my SKP file?
Match.skp (1.9 MB)


#11

I have new Dell XPS with Intel HD Graphics 615

I am using SketchUp 2018, but I am still part of the Free Trial to determine if SketchUp is right for my business.


#12

Unfortunately being new to you doesn’t mean the drivers are up to date. You shouldtry updating them anyway. Is the Intel HD graphics adapter the only graphics option on your computer? Intel is well known for not fully supporting OpenGL which SketchUp requires. Integrated Intel graphics are not recommended. You’ll need to watch out for automatic Windows updates, too. They frequently push Intel graphics drivers that don’t work well. This forum is littered with reports from users who find things don’t work right after they got a new Windows update during the night.

Did you open the SketchUp file I sent?


#13

I did download it and it appears right-side up in SketchUp, so now what does that mean? #ReallyConfused

I update my drivers.


#14

Dave,

It appears there’s an Update for my Intel HD Graphics 615. I am installing that now.

:crossed_fingers:

Drew


#15

Dave,

Unfortunately the driver update didn’t work. Here’s a quick jing video showing how my day has been going. This is happening to all pictures -

https://www.screencast.com/t/eOF6vVQsh6l3

Thanks again for your time and efforts,

Drew


#16

@Josh said that he’s seen this before, so maybe he’ll have some insight here. That’s very strange. @chamberz have you seen this before?


#17

@TheOnlyAaron & I encountered this… bringing him into the thread.


#18

I have seen issue in the past. I think that, as @daver touched on, it has something to do with some sort of data stored in the image or something. I was seeing it on my mac. My solution was to open the image in preview, rotate it one direction, then rotate it back and save it. Once I did that, it came into Match Photo just fine. Very strange and not something that occurs on every photo I took… Just some of them.


#19

Aaron, Drew emailed saying he tried that rotate idea and it didn’t work. Did you save it as a new file after you altered it? I wonder if that would do it.


#20

Update: Drew uninstalled and reinstalled SketchUp and then did a bunch of rotates in an image editor and re-saved the image file again, and then it worked! Thanks so much, @TheOnlyAaron !