Can't zoom in close on a point

Since the recent upgrade for Sketchup Pro 2020, I have not been able to zoom in close to a line or point in my model as I previously had. When I zoom in to get close to a line, the view seems to hit the “lens” of the camera and the lines cut out and disappear. Normally when this would happen, I would hit “zoom extents” and it would reset and I could zoom without issue again. Now after “zoom extents”, the issue still persists. This has always been a problem when in “perspective” camera view, but it is now also happening in “parallel projection”.

Anyone else having this problem or know how to fix this?

Thanks,

Joel

1 Like

You would switch to perspective, then zoom extents. There isn’t really anything different in 2020 in that regard, the same conditions should go wrong in SketchUp 8 or later.

There is a change in either 2020 or 2020.1 that breaks the parallel projection camera and makes it impossible to zoom into geometry.

1 Like

I found that happening quite a lot recently too. I noticed that when geometry started disappearing, hitting the space bar to cancel out of my current tool would generally sort it in that instance so I could continue with what I was doing.

I’m using 2020.1 also :thinking:

Continuing the discussion from Can't zoom in close on a point:

I have the same problem.
I’ve just changed from sketchUp pro 2019 to SketchUp pro 2020.
And this soom problem is driving me crazy.

Pleas can someone tell me how i can fix it?

Big thanks!

Perhaps you can share the .skp file that is giving you problems so we can see what you are working with?

Set the camera to perspective, then the Field of View(also under camera to something like 1-5)
[menu]Camera->Field of View
Type the angle, hit Enter

Makes sense but what angle?

Same issue
I believe I’ve run into this before and the solution had something to do with this camera and field of view thing . I’m also in 2020, I’ve attempted to adjust camera and haven’t found a way to do it. Mike’s instructions above didn’t get me there. (What us 1-5?) The vcb in field of view also didn’t want to be edited.
And my model is quite close to the drawing origin.

Select the Zoom tool from the Camera menu or Toolbar. Then type a new FOV. Just as with other VCB entries, do not click in the box. If you type a number followed by mm you will get a focal length instead. I generally model with the camera set to 85mm because I find the default too wide.

I hadn’t heard of that option. I tried it, and 85mm is a tiny amount under 24 degrees. So, 24 Enter would look much the same.

1 Like

@colin Now, do you intend to do something about it?
Same problem in Sketchup 2019… again, and again, and again, and again… This is so tiring…

For your camera, the setting should be perspective for super close zoom.

Which part is it that you’re asking about? With 2021 the zooming in close to things seems to be improved.

@colin
That’s your solution, Colin? Really? Upselling, for a bug you could have, should have fixed and once and for all solved some years ago.

With 2021 the zooming in close to things seems to be improved.

“Seems to be improved” is really truly encouraging and inspiring…

1 Like

I’m not a programmer on the SketchUp team, so I don’t get to fix things. I do report problems, and if you look at topics like this one, I have spent a lot of time trying to find solutions.

Hiding critical comments from customers is actually one thing. You may do that. But I do hope you do take the comments seriously and address the obvious problems that SketchUp brings about, and that so many people do problems with.

Today, I took the time to check to see wether “seems to improved” was working. I don’t know why, but hopes where high, but this is the result (see attached file).

What has happened is that other users have flagged your post as inappropriate. Colin has nothing to do with it being hidden.

1 Like

I wouldn’t hide critical comments.

I went on to do a test. This image shows SketchUp 2017-2021 zoomed in very close on a corner. The orange rectangle is 1/16th of an inch, so zoomed in quite a lot. I zoomed in until clipping occurred, then took a screenshot. I resized the screenshots so that the scale of the model was the same, to then show how bad the clipping was at the closest distance away that clipping starts.

You can see that in 2017 it was at a particular level of clipping, then got worse in 2018, but improved to better than 2017 for 2019. 2020 was about the same, but in 2021 it’s more like it was in 2018.

I will show the developers what I found, to see they can figure out what was reverted in 2021 back to the 2018 amount of clipping.

2 Likes

I tried zooming in slower in 2021, and got better results. Maybe it isn’t as bad as 2018 after all. I must try to find a more scientific way to do the test!

1 Like