Can't Unwrap Models In Maya After Exporting As An FBX


#1

Hello everyone, it’s me again with these damned models for my VR game lol :sob:

I decided to take a break from the corridors and do some props instead because I was sick to the death of the sight of my corridors lmfao. I’m going to need to UV Unwrap these corridors at some point so I decided to go for something simple to start with. 3 storage crates of different sizes that I can have in my opening scene in the starship’s docking bay. So I just created three different boxes. Well I did say I was going to start with something simple lol

So I exported them as FBX files and imported them into Maya. But when I started to Unwrap them I found that I can’t Move And Sew the pieces together.

I thought it was maybe something I was doing wrong so I tried the same thing with a box that I created in Maya and found that I could Move And Sew the pieces without a problem.

Has anyone any ideas what I’ve done wrong here please…? Thanks in advance for any help! :heart_eyes:


#2

did you add a material with a texture onto the faces (not the group/container) in sketchup?


#3

Nope, I just kept the material that SketchUp uses for front faces, I just drew a box and exported. How would I go about doing that please…?


#4

Its fairly basic. Have a look at a tutorial here: https://help.sketchup.com/en/article/3000113

Edit: for Maya to uv unwrap something, there must be uv coords in the object to start with. Without a material with a texture in SketchUp applied to the object, you won’t have uv coords for the object in Maya.


#5

I’ve tried that but still not having any luck. I’ve used the Paintbrush tool to apply a texture, when I choose the Automatic option under the UV menu and have a look at it I can see the boxes laid over the top of the texture but am still having the same problem. I can’t move and sew. I’ve tried with textures and colours but I’m still unable to sew these things together.

For reference these are the steps I’m following to do the UV Unwrapping:

When I follow these steps using a box I’ve created in Maya 2017 I don’t have a problem, everything works as it should. But when I export an FBX file from SketchUp and import it into Maya I can’t move and sew the pieces together.

This is starting to get frustrating now lol :sob: :open_mouth:


#6

I don’t have Maya so can’t help you with that. Lets try to find the actual problem here:

  1. can you upload your SketchUp file (box with the material + texture)?

  2. if you export to fbx, in your options, did you enable ‘export texture maps’ ?

  3. In Maya, do you see the material you applied on the box in SketchUp ? In Maya, if you select the material of the imported box, do you see the texture?

If you can answer the above questions, maybe we’re on the right track finding your problem.


#7

You must apply textured materials directly onto faces.
Applying a textured material onto a container [group/component] does not result in any usable mapping of that material.


#8
  1. Here’s a link to the FBX file: https://www.dropbox.com/s/izou4ktao9871hk/Untitled.fbx?dl=0

And a link to my SketchUp file: https://www.dropbox.com/s/n5xpyztd0e9f1pv/Untitled.skp?dl=0

  1. Yup, I double checked that’export texture map’ option was ticked.

  2. Yup, as shown in the screenshot below:

Once imported into Maya I choose UV>Automatic and the projections are off centre but moving them solves that problem (Not sure what causes that problem tbh). The projection thingies are shown in the screenshot below:

I then choose UV>UV Editor and see that the texture has been applied and is sitting in the right place as shown here:

But when I right click and select Shell, right click again and select Face and then move one of the faces when I right click to select Edge, hovering over the edges doesn’t show the edge that it’s connected to so Maya can’t Move And Sew the edges together.

@TIG I’ve tried applying the colour to each face separately with the Paint Bucket tool and am still getting the same problem. :frowning:


#9

Your material in SketchUp doesn’t use a texture. No texture=no mapping coordinates=nothing to unwrap in Maya.
A solid blue color is a material but without a ‘picture’ in the material as well ( bricks, wood, whatever) you will never get mapping coordinates in SketchUp.

Edit: in Maya, 3dsMax, Blender, you get / can apply, mapping coordinates in a different way compared to SketchUp. In SketchUp, the only way is to make a material that uses a texture and apply it onto the individual faces of the object.


#10

Someone on the Maya sub-Reddit has just pointed out that the UV Map doesn’t have the faces joined. There are small gapes separating the faces. Looks like that’s my problem.

I’ve put a texture on each face in SketchUp as you’ve suggested and when I export it SketchUp now creates a separate folder with the texture in it. But when I import the FBX file into Maya the texture doesn’t appear on the model. Perhaps I need to apply the texture to the model before starting the Projection and bring up the UV Editior…?

I’ve asked the guy that has pointed out the gaps and will post here if he gets back to me on this! :smiley:

Edit: The texture or material is there, I just need to press 6 to see it. But there’s no UV map. Is there any way that you know of that allows you to create a UV Map in SketchUp…? I’ve tried using the Paint Brush tool and applying a texture face by face but not having any luck.

I’m starting to think that I may just have to ditch SketchUp and go the long way and create all of my models in Maya which is going to take me CONSIDERABLY longer :sob:


#11

In SketchUp you can’t really apply uvs like in Maya / Blender / 3dsMax etc. There are several plugins for painting, there are even plugins that allow you to manipulate uvs but it will all come back to the same way these uvs are internally stored by SketchUp in the object. They don’t add a new way of storing uvs. No need looking there.

Back to solving (trying to) your problem:

  • by pressing 6, you see the material in Maya. So you see the pattern (brick / tiles etc) you applied in SketchUp? If so; Maya has received the material and the uvs. If not; something is still wrong.
  • If it has received the uvs; you could look for something like a Unwrap UV tool / UV Editor. If you select the object it should show some uvs. Maybe they are not in the center of the screen and you might have to zoom out quite a bit - SketchUp uvs sometimes are quite scattered.

Sounds to me you’re still new to SketchUp and Maya. I wouldn’t give up on SketchUp if you like its modelling flow - just keep looking for a solution. You could always continue modelling in SketchUp and just use Maya to apply materials and unwrap uvs. Although, using Maya just for uvmapping would sound like a big waste.


#12

Yesssssssss!!!

feynbear on the Maya Reddit has sorted this out for me! For anyone else having this problem here’s what you need to do. Select all of the vertices and merge them using Edit Mesh > Merge and that’s it. Job done!

Thanks ever so much for looking into this for me MaxB, so glad I’ve got this all sorted out! Ta! :grinning:


#13

Nice you have sorted it out!

I’m a bit confused though; you can’t see the uv coords until you merge the vertices? Strange, but at least now you can get on with the good stuff: modelling.

Good luck!