Can't set scale for Perspective view

In the latest version of SketchUp layout 2023 I’m not able to set scale for Perspective view, whenever I import my model and click on a scale and untick the ortho [parallel projection] the scale goes to default and it doesn’t go to what I have set? Why is it happening like this?? It is a bug or an international feature of latest version where you can’t set a scale for perspective anymore??

That’s right. It’s not a bug. Scale is a thing for Parallel Projection views.

1 Like

Dave is right. There is technically no such thing as a scaled perspective. You can however scale a section line of a perspective…called section-perspective. Only that line or part of the perspective is scaled. See Eneroth’s extension - Extension | SketchUp Extension Warehouse - if it helps at all.

This makes sense, of course, when you think about it. If something is locked in a parallel view, the length of a wall for example, is a specific length and that length is a specific percentage of the actual built length. If you are in perspective, the different edges of the wall will have different lengths in order to display the vanishing effect that is perspective. Because of this, there is not exact length that can be correlated to a percentage of the built length.

Eneroth’s extension works the same way a handmade perspective plan or section works.

first the plan / section in parallel, then the perspective going in the back. if done properly it’s a sexy drawing, but you’ll have trouble with large plans / sections : in the middle you’ll see a lot, but when you go far, you’ll see less and less of the rooms.

I had to do some by hand in my studies, and most of the time is was one room, two at max (like eneroth shows in her plugin presentation). Often, when dealing with a plan or section in perspective, you’d better just forget the scale factor and focus on it looking good / readable. and adding a regular scaled plan next to it.

in other cases, eneroth is here to save your day :wink:

I hear ya there. You can control the FOV which may help some but I can see where there are limitations to this method. Here is an attempt to make a group from a Section Cut…then ‘Stack’ that scene as a scaled Ortho plan on top of a perspective plan view. Not sure how successful this approach is.

pretty successful, but with the same limitations in the end. it’s an optic problem more than a software one.

I remember perspective classes (ugh, I hated that), you could cheat and divide your plan in different parts, each having its own perspective. but then it gives the impression you’re looking at a curved space.

In the end, it comes back to the question “what is this document supposed to show?”. space or scale ? I find that it’s rarely both, therefore one can take over the other :slight_smile:

In the previous version (2020) when I import my model and click on a scale and un tick the ortho [parallel projection] the scale stays and the model scales small or big as per the scale I have set

In this ss I have set to 1":5.5" and deselect the ortho
I want to scale so that I can get precise size numbers for my model rather than scaling it with random number

As was pointed out, Scale for a perspective view such as the one you show doesn’t make much sense. The scale you’ve set doesn’t really apply to anything in the model. If you don’t want the model to change size on the page as you change the size of the viewport, just tick the box for Preserve Scale on Resize. You can head off a lot of problems if you avoid modifying the Camera properties in LO.

If you share the LO file I’ll take a look at it and give you some ideas about how to handle creating the plan for your model. Send it to me in a private message if you don’t want to make it public.

1 Like

Yea ik I just want the scale to resize my model big or small and in previous version it was working flawless

In 2023 I was not able to change it so I untick the preserve on scale and dragged and make it big or or small as I needed but I don’t want this coz if I have precise numbers then I can use that numbers in different scene of the model so that they both line up rather than doing it manual for every scene if they are same

How can I send you the LO file in private message? I’m new to forms so I don’t know

You can do that by simply resizing the viewport if you untick Preserve Scale on Resize.

If you set up the scenes correctly you don’t have to screw around with nonsense scales in LayOut. Also, it doesn’t make sense to include the scale on the page since the Scale is meaningless for taking dimensions off the view.

Click on my name and then “Message”. Drag and drop the LO file into the message. If it’s larger than 16 Mb, upload it to DropBox and share the link.

1 Like

I don’t remember being able to scale a viewport to an specific scale when it was on perspective, if you see the image you shared, the scale section of the sketchup model tray is gray, that means that you can’t change the scale, to do that you must check the Ortho box, but that will change the viewport to a isometric projection.

You can’t and never have been able to set a scale while the camera is set to Perspective. He wrote that he set the scale while the Ortho box was ticked and then unticked Ortho. That was borne out in his LO file, too.

1 Like

Everyone seems so quick to jump to the conclusion that if anything in layout isn’t working ideally you are an idiot and doing everything wrong! They clearly can’t understand your question. If you follow the link below to a thread I started you can scroll down the the reply from Adam where he admits layout '23 is broken. Still waiting for the update to fix this. For any die hard layout defenders, you can see in the video I posted what we are referring to.


yeah, you’re mixing two issues there my dude.
and by the way not a die had layout defender, nor a keyboard warrior. just a guy with a different opinion. but sure, polarise the discussion, that’ll help. nothing like being called out to motivate people to come help. good strat.

  • when it comes to his original question, PRANEETBANE is indeed mistaken. There is no “scaled perspective” in layout

a “scaled drawing” and “preserving scale” are different things. the first one is a drawing, in parallel projection (ortho) where lines are drawn at a specific scale. 1:100 for example. meaning 1cm on paper is 100cm in reality.

“preserving scale” just means that when you make the viewport bigger or smaller, the model inside will remain the same. if won’t get bigger or smaller, just the viewport. if your model is in parallel and you’ve set up a scale, 1:100, then it will remain 1:100.
but if your model is in perspective, it will just remain the same size no matter how much you change the viewport.

Now, the issue in the thread that you linked to is the “preserving scale” issue. meaning that by ticking “preserving scale”, the model still gets smaller. and that’s what Adam refers to when he says that indeed, the “preserve scale” has a problem. that’s the bug, and they are working on it.

so what’s the deal with PRANEETBANE ? well he might be a victim of the “preserve scale” bug just like everyone else, but other than that, he is asking layout to provide a scaled perspective while it can’t.

  • Layout can’t natively provide a scaled perspective. it never did.
  • the image PRANEETBANE is showing us as being “scaled at 1:5,5” is not scaled. can’t be. even if I were to draw it by hand, using the old art of 3 point perspective, it still wouldn’t be scaled. because it’s perspective.
  • right now in layout 23 we can’t force a viewport to keep the same zoom, and it’s broken. you’re right on that.

two separate issues.

the fact that when you select a perspective viewport, there is a scale provided in the panel simply means “yo, this was the scale back when the viewport was parallel”. that’s why it is greyed out. because it’s not in use anymore. (I mean, obviously, it shouldn’t display anything but hey, layout is broken, your words not mine)


This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.