Can't set printing quality

Can’t set printing quality. there is no option to choose in print setup. I just reinstalled sketchup on new computer. I’m using SK2017Make. Could anybody help me with it? Thanks.
Piotr

Print Quality in SketchUp isn’t set in Print Setup. It is selected in Print or Print Preview.

Dave,

Thanks for your respond. Problem is my “print Quality” window is blank, isn’t pop up any option. On pervious computer was possibility to choose options as on your photo above. I downloaded also SKpro version and there is same issue. I’m using same printer as with previous computer HP8710.
Piotr

Make sure the printer drivers are up to date.

Did you install SketchUp correctly by right clicking on the installer and selecting Run as administrator?

Dave,
as you suggested , printers drivers updated, I even reinstall my printer, I reinstalled SU, problem exist. Selection options not showing on Print Quality, on Scale units not showing up.

Open Print Preview. Click on the Printer Properties button and change to Landscape.
Then back in Print Preview, check fit to page and Use model extents.
Then just click OK so you get a default preview. This will create default print settings.
Then click the Print button (upper left) and the dialog reappears, but this time the page sizes and scales have values and you can now change the Print Quality.

Apparently when there are no default print settings yet setup the dialog has blank controls.

Dan,

I did everything as you describe, still Print Quality and Units its opening but there is blank controls noting to select. Sorry. How ever thanks for your help.

Well it worked for me. You did have geometry displayed in the view at the time, yes?

A very basic question, have you checked that your printer is recognised by both your pc and sketchup.

Yes, by both.

Yes Dan.

Well, if it hasn’t yet been suggested I’d say try to Repair the installation.
Find (or re-download) the installer executable, right-click it and choose “Run as administrator”, then choose the Repair option. Reboot computer afterward.

Sorry Dan, doesn’t work also. In my opinion there is some issue between Win 10 and Sketchup. On my old computer was Win 7, as soon I moved to Win 10 this issue appeared.
However thanks Dan for your time.

Does it help if you choose a different printer ?