Can't set default opacity for front/back of surfaces

Hi all,

I’ve been using sketchup for a little while now, but I’ve only just started playing around with settings for faces and styles. One thing has me really confused. I can successfully edit my current style, changing the front and back colours, and new shapes I draw will use these colours. I can also paint faces with the bucket tool/the entity info dialog, and using these methods I can change the colours and the opacity as I would expect. The problem comes when I try and set the default opacity to something other than 100% in my style - it simply ignores it! It will pick up whatever colour I’ve asked for, but the opacity of the new faces is always 100% until I manually override it for the shape in question using the entity info/paint bucket tools. I have enable transparency on and transparency does work generally - it’s just that sketchup isn’t picking up my opacity settings from my style for some reason. Is this a bug or am I missing something? I’m on a Mac on Yosemite, if that makes any difference.

Many thanks
Lucian

I think you are missing Xray mode. Turn on the Styles toolbar, and you’ll see it.

Ah, I should probably have explained my motivation for doing this a bit better. As I understand it, X-ray mode makes all faces in the model transparent from all directions. What I actually want is to set the outside faces only as transparent for all new objects, in order to do something like this: http://sketchupdate.blogspot.com/2011/11/getting-better-view-of-small-interior.html . Apart from satisfying that use case, I’m also just generally curious why the opacity setting for faces in the styles dialog doesn’t work…

Cheers,

Lucian

Does your current Style have ‘transparency’ set ?
And also check that it’s NOT on Monochrome mode - but one of the others ??

Yep, transparency is on, and I have the default shading (“Display in shaded mode”). As I mentioned in the original post, if I manually paint the sides of an individual shape with a transparent fill, it works ok. The only thing that doesn’t work is the application of transparency as part of the default style. In your image above, if you change the “front color” to a fully or partially transparent color, and then draw a new shape, what happens?

Thanks,

Lucian

I think I’m missing something, where do you change the opacity for the standard front and back color in the styles settings?

You have no alpha setting for the ‘default’ material ?
But all other materials can have transparency.
If you apply a material to a face the result might vary from one applied to a group/instance ?

As shown in @Cotty’s picture, the default faces may only be solid colors. There are no textures and no alpha settings. I don’t believe the blog you cited said to make the default face color transparent, did it? Just to make exterior faces transparent.

As for getting a view of interior spaces, you can simply use layer visibility, saved and toggled with scenes, to make the walls invisible when you don’t want to see them. There are actually several standard ways to gain visual access to interior spaces in SU. Aside from layers, you can use sectional views or saved interior view states (saved in a scene with the camera inside the structure). Or, you can do it as directed in the blog, but I think in the example the walls were explicitly painted with a transparent material; it was not a default.

-Gully

1 Like

Gully has nailed it (again!). You can change the front and back colors for the default material, but you can not change its transparency. You can do so only for other materials.

Hmm. I think maybe this is a mac thing then. This is the UI I get when I click on the color options for my style.

As you can see, I can set the opacity, and this is reflected in the front and back color displayed in the styles box. It just doesn’t work when you use it. @Cotty looks like he’s using a PC. UI bug on mac?

Lucian

No, I’m also on Mac. The opacity slider is there, but it doesn’t “take” when you use it on the default material, only on other ones.

On a PC there is no confusion - because when you edit the default material [front/back] in your Style you just get RGB settings.

1 Like

Yeah, as @TIG has pointed out, this is handled a lot better on the PC where you don’t get the option to specify an opacity that won’t work. Is there a way to raise UI tickets for Sketchup or is it basically just these forums? It seems like in an ideal world the opacity slider would be hidden or disabled when editing the default colours.

Cheers,

Lucian

Currently the recommended way is to report bugs in the forum, or for crashes to add a detailed description in the bugsplat reporting system.

This issue has just been reported (SketchUp 2015: SU-0200).

Hey everyone! I have a question related to the initial post:
is there a way to adjust the settings so that when I assign a transparent material onto the surface it becomes transparent only on the indicated side of the surface?
For now every time I click on the face with the Bucket instrument, the transparent material is automatically assigned on both sides of the face…

@AnnaSH, paint an opaque color or material to the opposite side to get what you want.

This commonly used to allow SketchUp’s sun to shine through ceilings for interior views.

hey DaveR! Thanks for your reply!
Do you mean assigning the opaque material manually?
This way is known to me. But it is uncomfortable to paint e.g. 14 windows on 5 floors from the other side… I was wondering if there is any way to change the default setting…

Are your windows all unique? If there are instances of the same component, you should only need to edit one to get to the inside face. And you can pull out a copy to work on away from the building so you won’t need to go inside.

There’s no way to prevent the default face colors from behaving the way they do when you apply the transparent material to one side. It’s an intended behavior as it is since typically things like windows would be transparent from both sides.

1 Like

I see, thank you for the tips! I use the trick with copying, but other than that it also happens that I have unique glazing pieces…
I am using SU for my experiments with room acoustics, and the plugin takes into account all the surfaces with the assigned materials, so having material on both sides is no go for me…

Then you might need to change the the way the windows are made. Or maybe you need a transparent version of the windows and an opaque version. Swap the opaque versions in when you need to run the acoustics plugin.

Maybe you could make the windows dynamic components with two different materials for the glass.

1 Like