Can’t set default opacity for front/back of surfaces

sketchup

#1

Hi all,

I’ve been using sketchup for a little while now, but I’ve only just started playing around with settings for faces and styles. One thing has me really confused. I can successfully edit my current style, changing the front and back colours, and new shapes I draw will use these colours. I can also paint faces with the bucket tool/the entity info dialog, and using these methods I can change the colours and the opacity as I would expect. The problem comes when I try and set the default opacity to something other than 100% in my style - it simply ignores it! It will pick up whatever colour I’ve asked for, but the opacity of the new faces is always 100% until I manually override it for the shape in question using the entity info/paint bucket tools. I have enable transparency on and transparency does work generally - it’s just that sketchup isn’t picking up my opacity settings from my style for some reason. Is this a bug or am I missing something? I’m on a Mac on Yosemite, if that makes any difference.

Many thanks
Lucian


#2

You may have not yet understood its purpose, the default material is a “None material” or “undefined” or “null”. It is not supposed to be used to give drawing elements a color, but to define what SketchUp should render if a drawing element has no material or color. Your 3D printer will not print any color for these objects.

  • If you want to give objects a material/color specific to the object, create a new material or import one from the material libraries.

  • If you want help to detect incorrectly oriented faces (front face/backface) or unpainted faces, set the default material color to something striking, and the backface color to the opposite.


#3

If you want to view your model in a transparent style, you can turn on X-ray mode in Face Styles.