Can't see axis lines or drawn objects

I’m new to Sketchup. I downloaded the 2016 Pro version today.

The screen didn’t show the standard three axes lines, and anything I tried to draw didn’t show up. However, I could select them if clicked where I drew the object. I could also see the prompts in the bottom telling me how to start and close a rectangle.

I closed the program, reopened it, and it prompted me to download 2018 instead. So, I uninstalled 2016 and loaded 2018, 64bit. Same exact issue.

I uninstalled 2018, then reinstalled it. This time I could see the axis lines, but still couldn’t draw a shape. I ran through all my potential driver updates, and had a windows update. Did the update, restarted the computer, and… I’m back to a blank white screen.

I’m also seeing a large lag when I click any thing. When I try to draw, select the items I drew (but can’t see) even just click on the screen, I’ll get a ~5 second lag. I know there’s a plug in that just dropped that should help the lag, but I haven’t seen anything on missing all visuals. I’ve uploaded a screen shot.

Any help would be really really appreciated. Thanks!

When you installed SketchUp did you right click on the installer and choose Run as administrator? If you didn’t, SketchUp is not installed correctly. Find the installer and right click on it. Choose Run as administrator and then the Repair option when it presents. After that, try opening SketchUp again and see if that helps.

Another thing to do is make sure that your Nvidia card is actually being used for SketchUp. Do that in the Nvidia control panel.

That seems to have fixed it! I uninstalled and reinstalled as admin. Nvidia card was being used, but some of the settings weren’t the required settings. Thank you for the help!

1 Like


I thought I was good but apparently not. I had the same exact problem with 2018 today, so I decided to roll back to 2017. Figured there’d be less bugs there. Buuut it seems not.

I have my Nvidia card set to the proper settings, and told it to run sketchup. I installed by downloading the installer, right click and run as admin. The first time I opened the program, it looked fine until I resized the window and the corners smeared. I close the program, reopened, and now it won’t give me an image at all.
Any other thoughts that could help? Much appreciated.

That’s the kind of thing that is typically a graphics card issue. If you set the SketchUp window to full size by clicking the square between the - and X in the upper right corner, what happens?

And you’re still seeing no axis lines?

That set me in the right direction.
I’m running a dual monitor setup for the first time, and that was my downfall. My card only has one hdmi output, so I plugged one monitor into the mobo and one into the gpu. When I move sketchup onto the GPU powered monitor, it runs wonderfully. When it’s on the mobo powered monitor, it crashes hard. I just ordered a DVI to hdmi adapter so that I can run both off the gpu and not have this issue anymore.
Thanks for the help!

1 Like

Excellent! I’m glad you got that sorted. It’s not something I would have guessed but I’ll try to remember it the next time someone has a problem.

Hmmm, I would have said that info would have helped o diagnose the issue.

You are entirely right. As I said, I’ve never ran a dual monitor setup before, so I didn’t even think to mention that.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.