2018 Start Up Glitch - No Axis/Grid

bug

#1

Hi All!

Recently downloaded the Full version of 2018 Sketch Up. Everything worked wonderfully until I plugged in my license credentials. Now when I open the program, I am given a blank plane, with no axis/ grid. I can’t zoom out or in, and non of my tools seem to work or create shapes. I have tried importing previous projects, however I am still met with a blank plane.

Things I have done:

  • Uninstalled/ Reinstalled the program
  • Ran SketchUp Diagnostics Plug In (Everything passed)

Has anyone else had the privilege of dealing with this glitch? Any help would be greatly appreciated! :slight_smile:


#2

Since this is caused by your graphics card and neither of those things have anything to do with correcting the graphics driver’s deficiencies, it’s not surprising that they didn’t work.

Go to Window>Preferences>OpenGL. Untick Use Fast Feedback. Any change in behavior?

Please correct the information regarding your graphics card in your profile.


#3

Yes! This fixed the problem, Thank you soo much! :slight_smile:


#4

You should fill your Infos here…


#5

Thanks, Cotty and @DaveR! If (or rather - When) you see this come up again, please refer people to this post: Blank Screen? Fill out this form and get the top solutions!
instead of answering the question for them directly. Just for a while until we can collect sufficient data about the issue. Thanks so much for all your help!