Can't save file, or download file

I have been using Sketchup web free for years. I have lots of saved files. Have opened and changed an existing file, but cannot then save it. Get this error:
image
Tried to download to hard drive, but get this error:
“An error occurred while downloading the model.”
which causes the session to lock up (only way out is to close browser tab.
Using Win10, Chrome Version 102.0.5005.63 (Official Build) (64-bit)

I moved this from the LayOut category because it’s not about LayOut.

How large is the SketchUp file? Have you tried purging unused components and materials before saving or downloading?

File size is 18MB. Yes I have purged components and materials.

What happens if you open a new SketchUp session in another tab? Can you draw something simple like a cube and save that?

I tried deleting everything from file, and answered yes to ‘purge before save’ but still wont save.
I Opened the file and immediately did Save As. answered both Yes and No to ‘purge before saving’ but just get:

STarted New blank file, then did Save As. That worked…

Is a very simple file. I manually purged components (have none) and materials (have now only 2) but still get asked to purge file when trying to save. Saying yes or no just gives fail message

Might be a style that needs to be purged.

So Save works, just not with that file.

Can you export a .stl file successfully?

Here’s a real time example of what I see when I save. This file is 16 Mb and I’m using the same version of Chrome you are.
save

Someone at SketchUp saw the problem yesterday. I’ve asked if there was a solution, or if the problem is ongoing.

Related to a specific server maybe?

User’s available storage too full?

So, I went to Trimble Connect, downloaded the file as .skp file successsfylly. then started a blank sketchup session and did an Import_>My Device and it loaded in fine. then I was able to file Save As into my Sketchup folders. That seems to have worked fine, but… I exploded the imported ‘component’ and deleted a single piece of text, and now it is back to the same problem. Can’t Save, Save As, or Download the file…

No, my memory isn’t full. Its 10GB right? I have couple dozen files, but they are all small. My entire Sketchup directory is shown as <600MB

cannot download ‘export’ to .stl or .skp file. the .png file downloaded, but that is not very useful.

The model has no un-used Style. Using the Default Style
image

Would it be possible to see the file that you uploaded, before the explode step?

I really meant a copy of the SKP file, not a screenshot of what it looks like. You could use WeTransfer or Dropbox to post the file.

Hi, jettrentini. Your error messages look rather unusual so I reviewed our error reports and found some information that suggests your device might have had a problem with local storage or memory. If you have any other device capable of running SketchUp for Web it might be worth trying.