Can't sample existing material texture anymore on 2024 version

Hello

I have just updated to 2024 version. I run PRO version.
I was used to double click ANY texture material swatch to either adjust the color and apply to other faces the same texture.
Now its just doesnt work.

For adjusting existing location, I found that I had to at least double click a swatch in the (color in model) folder to adjust it.

But I cannot reapply it to an other face in my model.
It revert back to an other selection.
Using the eyedroper tool form the color tools only select a plain color.
I had to double click a swatch, then an eydropper tools would appear to select a texture, then it would be able to apply anywhere else

Any help

I’m on Sonoma and it works as expected. I’m asking internal people on older versions to try it for me.

b

The eyedropper in the Colors palette does only pick a screen color. To pick up a material you want to single-click on the material in the Colors palette, or be on the Paint Bucket, and hold or tap Option to then pick up the material from an existing face.

What has changed in 2024.0.1 is that to edit the settings of a material you need to either double-click it in the Colors in Model set, or right-click and choose Edit, in the Colors in Model set. Try either of those things in another set of materials will show this message:

That change was to solve another couple of issues, one of which could lead to crashing.

There is one thing that is misleading about the message. If you double-click on a material that is used in the model, but you do that in the material’s original set of materials, you will see the message. You need to switch to Colors in Model if you want to edit the material’s settings.

2 Likes

Thank You!
Its been resolve.
For me its actually have been:

  • Select Paint Bucket
  • Command + Click on face to sample.

I also notice the bottom bar info/tups.
That functions was written when I tried your Option+click.
Thank you for that!
Ill try to notice those shortcut for my productivity.

1 Like

To reply on the misleading double-click… I have been using Sketchup for 10 years or so and always double clicked ANY Material in any folder for revealing the eyedropper material sample.
I never had the message or had to select it from “color in models”…
Ill get used to the new function, thanks

Right, it is Command. I got myself mixed up because it’s Alt on Windows.

1 Like