Can't rename tags (layers) in 2021 Pro

Bit of a bug in the ability (or lack of) for renaming tags (or “layers” as everybody in the real world refers to them!)

If I click on a lay… sorry, tag … and then click again to open the name field for editing, SketchUp behaves as though I’ve immediately hit “Enter” or “Esc”. End result: can’t rename any tags. This is the same whether the Tags tray is pinned, floating or set to auto-hide.

Anybody else experiencing similar behaviour?

image

No issues here, even double click works.
Tag Rename

It might be one of those weird issue you get if you didn’t install using the right click on the downloaded install .exe Run as admin method. You could do that now and choose repair and see if that fixes it.

Turns out that going the admin/repair route makes things even weirder, because now I can edit some tags, but not all. If anything that’s actually worse! A workaround is to open Notepad, type in the new tag name, copy the text, then quickly paste that into the tag field when it opens for editing (in the milliseconds-long window of opportunity before the field closes again).

Next step is to see if the behaviour is replicated on my desktop machine. If it is then I’ll ping support to fix the bug!

1 Like

Double clicking on the tag name to edit it works fine for me here. I’d be looking at your mouse if that isn’t working for you.

If it was a mouse issue then that wouldn’t affect some tags but not others, it’d be all or none. And I’d be having issues in other packages, e.g. AutoCAD, Infraworks, Office - all of which are working fine.

1 Like

Someone internally mentioned this a couple of days ago. I will write up a bug report if I can’t find an existing one.

The steps to make it go wrong are: select a tag, then any amount of time later try double-clicking to rename the tag. The other important part is that the tag name needs to be long.

The work around is to make sure the tag isn’t already selected.

I didn’t install mine with this right-click method and I can double-click and rename tags. Got to be something else.

With Windows installing any complex app from its installer’s exe file in any other way [ i.e other than …>context-menu>Run as administrator] is a recipe for future unpredictable problems, often revolving around permissions, preferences not remembered across sessions etc,.
I earnestly recommend that you ‘Repair’ your installation… otherwise one day [probably unexpectedly and seemingly randomly] your incorrect installation will come back to haunt you…

1 Like

The length of the tag names is important with regard to this bug.

1 Like

OK except NOTHING else “requires” this type of install. Not AutoCAD, Revit, Photoshop, Illustrator, SimLab, Form Z, Blender, Dimension or any other program I have on my 2 PCs. All of my programs including ALL of my SU installs work perfectly. There is no way that I have been “just lucky” 100% of the time. Agree to disagree :wink:

So not install method?

A sloppiest install, or a most perfect install, would still show this bug.

2 Likes

Thank you Colin :slight_smile:

If you read through the threads here and at SketchUcation you will find countless instances of a ‘non-administrator’ [aka double-click ‘Run’] installation causing very weird issues.
No one is forcing you to do it properly. :face_with_raised_eyebrow:
After all you might be blessed, or have your overly-complex Windows-users permissions set ‘just-right’…
But many don’t and do get weirdness.
Perhaps this Tag-name-edit problem relates to something else entirely, but installing SketchUp from its exe properly will never hurt…
If you already installed it ‘wrong’ then a reinstall of the installer’s exe, using the >right-click>context-menu>Run as administrator… the choosing Repair will reset thing without uninstalling or messing you any earlier personalization…

I now see the ‘bug’ with very long Tag names, however on Windows if the click on the overly-long name and leave your cursor ‘in line’ with the selected block of text [off towards its right end] then you can select/edit/rename as expected.
Moving your cursor out of the line stops it being editable…
I guess it’s a ‘focus’ thing that can be corrected with re-coding of the dialog…
Meanwhile ‘select’ it carefully…

The length has to be long enough to trigger the Windows help tip (the one that shows you the missing characters). That help tip doesn’t always appear, but if the name is short enough that the help tip certainly won’t appear, the name seems to edit ok.

Making the name be less long would be a solution, and with Tag folders that may be a more practical solution. The folder can say a lot about the category, and the tag itself can say more about the subcategory. Not as much need for very long names.

And again no other software “requires” this…none. Many are FAR more complex than SU. All I can comment on is my OWN experiences. I 1st started using Acad r9 on DOS. My 1st SU use was on r3.
My PCs (home and work) are both Win 10 Pro but work is managed by work the other is by me and is a plain 100% vanilla install, there is nothing special going on.

1 Like

Just for the hell of it I have always installed SketchUp by logging in with my admin account and installing. I have never touched the internals of my Windows account settings so the privileges are what mr. Gates has seen appropriate to assign to an admin account. Installing has always worked without problems.
I suspect that some antivirus/firewall applications are introducing additional read/write limitations that aren’t lifted until you follow the right-click choreography. Norton doesn’t seem to do that.

2 Likes

No idea myself but I’ve always just double-clicked and ALL of them have worked 100% of the time. No Norton here myself .Just Windows security at home and Endpoint (I think) at work.

You’d think that if sketchup was meant to be installed a certain way it would be deployed to do that. Weird they would still release an installer that is intentionally installing incorrectly. So weird.

1 Like